NTFS drive not automounting after fstab edit

Hi, I have an NTFS drive I want to be automounted at startup. I managed to do this several times in the past, but those steps do not seem to be working now.

What I do is pick the UUID of the drive (as seen in the output of fdisk -l) and add the following line at the bottom of /etc/fstab file:

UUID=08FB3989-C0E6-4A3F-B9E0-5AB48225FB12 /home/svalbardsleeperdistrict/Data ntfs-3g noatime,x-systemd.automount,x-systemd.device-timeout=10

Where the Data folder is the one I want to use for mounting it. I save the file and reboot, but the drive is still not mounted until I do it manually. Am I missing something?

Really? You use the disk identifier instead of the partition identifier?

lsblk --fs
1 Like

You may be the way also if on kernel 5.15 or later want to use type “ntfs3” rather than “ntfs-3g”. Latter is the historically used FUSE-based userspace NTFS filesystem driver, former a new kernelspace one that should be nicer/faster.

Thank you for the reply. I must have had wrong notes from previous times that misled me to using the drive UUID.

Thank you for the suggestion, I have now replaced that section.

Seems like I didn’t get permissions to paste files in this shared drive, so have to run sudo nautilus/terminal every time I want to move files there. Is there any way this can be changed and I can get sudo permissions by default when accessing it?

Answering that very question for the ninehundredsixtythird time on the Linux Mint forum was in fact one of the reasons I stopped considering the Linux Mint forum to be a perk of Linux Mint but…

NTFS is not a UNIX-type filesystem and specifically does not support (basic) UNIX-type credentials. To a UNIX-type system such as Linux they are however fundamental and to then still fit a filesystem such as NTFS into the UNIX-model Linux simply “pretends” that files/directories on it have them. By default any file/directory on the filesystem gets the mounting user as the pretend-owner (normally “root”) and has pretend-permissions set halfway reasonable.

Given those defaults you are however indeed not granted rights to write to it as user and/but NTFS-3G compensates by mounting also with the “allow_other” filesystem parameter. Being somewhat of an affront to the standard UNIX permission model I’ve never cared for it doing that – and in any case this allowance was/is never made for e.g. FAT (which shares the same issue) and now not for “ntfs3” driven NTFS filesystems.

You can and as far as I’m concerned should adjust those mentioned “pretend credentials” at mount time by having in /etc/fstab e.g.

UUID=\<...\> /home/svalbardsleeperdistrict/Data ntfs3 noatime,uid=svalbardsleeperdistrict,gid=svalbardsleeperdistrict,fmask=133,dmask=022,x-systemd.automount,x-systemd.device-timeout=10

uid=/gid= sets owner:group of all files and directories on the filesystem to svalbardsleeperdistrict:svalbardsleeperdistrict and fmask=/dmask= sets permissions for files/directories to 644 /755 (i.e., normal). You can then simply use the fs as user svalbardsleeperdistrict without sudo.

Of course, if you need more than users than just svalbardsleeperdistrict to be able to write to the filesystem it may make sense to after all use allow_other instead (although, note, untested if that actually works with ntfs3). Certainly the best solution is to under UNIX-type systems not use non-UNIX-type filesystems such as NTFS – but hey.

1 Like

Thank you, I will attempt this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.