Notify-send screen positioning wrong

Hi

I use notify-send from my scripts etc.

Using the “Notifications” tool I can tell the system where to display the notifications.

“Top left” and “Bottom left” work fine.

“Top right” and “Bottom right” work, but the notifications are displayed in the MIDDLE of the screen.

These used to work perfectly but seem to have gone astray following a recent system update.

Is there some knd of configuration script for notify-send that I can examine for clues etc?

Thanks

Hi @rpi,

While I don’t use Xfce and can’t comment on the accuracy, a quick search led me to this page. There it turneed out to be because of notify-osd. So check if that’d installed, if it’s running, and if so, disable it:

To check if it’s installed:

pamac search notify-osd

Example:

$ pamac search notify-osd
[...]
notify-osd                                                                                                                                                                                                               0.9.35+16.04.20160415-3  community
Canonical's on-screen-display notification agent, implementing the freedesktop.org Desktop Notifications Specification with semi-transparent click-through bubbles

If it is installed, it’ll have an [installed] label next to it.


Note:

From here on it’s only guesswork, nothing else.


See if you can uninstall it:

pamac remove notify-osd

If that isn’t viable, see if you can disable and mask it, because it looks like a daemon/service to me:

sudo systemctl disable --now notify-osd.service && sudo systemctl mask notify-osd.service

Edit:

Combine it with @ishaanbhimwal’s answer :point_down: , probably.

1 Like

Open the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-notifyd.xml and append value=2 for Top-Right for the property notify-location:

<property name="notify-location" type="uint" value="2"/>
End result
<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-notifyd" version="1.0">
  <property name="primary-monitor" type="uint" value="0"/>
  <property name="notify-location" type="uint" value="2"/>
  <property name="log-level" type="uint" value="0"/>
  <property name="log-level-apps" type="uint" value="0"/>
  <property name="theme" type="string" value="Default"/>
  <property name="applications" type="empty">
    <property name="known_applications" type="array">
      <value type="string" value="MSM Notifier"/>
      <value type="string" value="nm-applet"/>
      <value type="string" value="notify-send"/>
      <value type="string" value="Package Manager"/>
      <value type="string" value="Xfce volume control"/>
      <value type="string" value="Xfce4-notifyd settings"/>
      <value type="string" value="xfce4-power-manager"/>
      <value type="string" value="xfce4-settings-helper"/>
    </property>
  </property>
</channel>

For Bottom-Right use value=3. You can test if this works with:

notify-send -t 3000 hello

You might have to reboot for changes to take effect.

1 Like

I just checked, my installation already has that value set:

property name=“notify-location” type=“uint” value=“2”/

But then I realised it might be a weird interaction with my instance of ‘Conky’.

I checked the Conky config and set the window type to normal (it was previously ‘panel’) like this:

own_window_type = ‘normal’,

It works perfectly and notifications now appear top right.

Thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.