Not requested Nextcloud autostart automatically

after the first upgrade of this new year (2024) the graphical client of Nextcloud starts automatically asking to be configured.

It does not start at login (auto-execution is disabled) but during the regular operation of the OS. I use a cli version of the client managed by cron. Before the last upgrade, everything was fine.

Any ideas about the trigger that runs Nexcloud graphical client?


$ sudo pacman -Fyl nextcloud | grep '\.service'
nextcloud usr/lib/systemd/system/nextcloud-cron.service


systemctl status nextcloud-cron

(+ systemctl disable nextcloud-cron --now, else systemctl mask nextcloud-cron)


systemctl status nextcloud-cron
Unit nextcloud-cron.service could not be found.

Oops, guess it should be

systemctl --user status nextcloud-cron

Again… Strange

systemctl --user status nextcloud-cron
Unit nextcloud-cron.service could not be found.

That’s wrong, you want the client not thr server.

How did you configure it and which package did you install?

Sorry, I do not understand. I have installed only the client here, and I use only a command line sync.

pacman -Ss |grep -i nextcloud |grep installed
extra/nextcloud-client 2:3.11.0-3 [installed]

The client GUI seems to start randomly…

I did not configure the client because I pass all the parameters from command line. I am the only user of the computer running the client and… using a ps aux |grep -i next the password has printed in clear.

So, no particular configuration, only the default one.

at .config/Nextcloud/nextcloud.cfg 


nextcloudcmd --version

Nextcloud version 3.11.0git
Git revision f91ae00cfa5113e0991d7c476460c8f55a80990f
Using Qt 5.15.11, built against Qt 5.15.11
Using 'OpenSSL 3.2.0 23 Nov 2023'
Running on Manjaro Linux, x86_64


Confirmed systemd. Why it is not found by command line check?

(pstree result with focus on nextcolud process)

So … I rechecked the client package:

$ pacman -Fl nextcloud-client | grep '\.service'
nextcloud-client usr/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service

So its a dbus service.


Is very roundabout.
Just use pacman -Qs nextcloud


As first, thanks. I try to study dbus system.

busctl --user list |grep -i next
com.nextcloudgmbh.Nextcloud                                        - -               -     (activatable) -                 -       -

Does exist a command line to mask or disable a single “dbus service”? Nextcloud, for example.

I would avoid manipulating files on the filesystem to maintain the system’s integrity.

At last, why nextcloud run if its state is activable? It should run if the state is active, not activable. Isn’t it?


I know you can override them similar to how you would a desktop file.

cp /usr/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service ~/.local/share/dbus-1/services
micro ~/.local/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service

(sorry, not an expert in nextcloud … or dbus for that matter… which has something of a documentation problem :sweat_smile:)

1 Like

The dbus service might be a sign of upcoming virtual file support like it is available under windows (sync on access). I also found a filetype registration for *.nextcloud files which might be the corresponding proxy files.

See: Nexcloud Forum Virtual Drive for Linux
(the question is about a different topic but the first answer covers the virtual file topic)

on how to activate the experimental functions.

1 Like

I’m not too fond of virtual files. I usually use Unison on my computer, but I have not found a decent client for my old Samsung Galaxy pro 12.2 lte SM-P905 (I do not remember if it is an Android 5 or 6, ).

I have an exchange folder to share data with Linux and Android.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.