Not possible to set “Alternative Characters Key”

I have just noticed the stable update for Gnome42, I have not updated yet… but I do have another partition with stable Gnome42 distro.
I’ve noticed it’s not possible to set “Alternative Characters Key” in Gnome 42 [Settings > Keyboard] - this facility seems somehow broken. (eg: select ‘Right Ctrl’ it will revert to ‘none’)
How about Manjaro Gnome42? Can you set the alt-char-key as expected?

I can set the option to right Ctrl in GNOME 42 and it sticks, I’ve not logged out or rebooted.

Good to know. Perhaps it’s only an issue in Ubuntu.
My question is a little redundant now since the stable is out, I wasn’t aware when I first posted.