(not) installing Epson ET-2850 printer

I’m trying to set up an Epson ET-2850 printer, and nothing is working; I downloaded the driver from the (unsupported) site the Epson references and also from something called AUR (not even sure what that is). CUPS doesn’t show the 2850 as an option, so I tried other similar models (2830, 2840 etc,) but the most I’ve been able to get the printer to do is feed a blank sheet of paper. Also tried something called “snapd” for driverless printing, but that didn’t work either. I’m at the end of my rope here. If there is not a clear and understandable process for doing this, I’ll have to throw the Epson in the swamp and go crawling back to HP!
Any Suggestions? thanks.

I have an ET-3850 which works great with Manjaro. As I recall, I first connected the printer to my wireless networks, and then in Manjaro the printer was detected on the network automatically in CUPS. I just chose the IPP Everywhere/universal driver.

if you had used the forum search for “epson 2850” you would have found a topic that explains that you need to run the avahi-daemon for your 2850-epson

See also Printing - Manjaro

It’s the Arch User Repository. You should read this link before using it, and be careful about what you install, because anyone can upload software there.


Thanks, that is helpful; I installed the print manager, it identified the printer and located the driver, but then when I got to the “describe printer” page I got;
CUPS server error
there was an error during the CUPS operation: ‘server-error-internal-error’
…and I’m stuck again.

I tried the print manager again and it seemed to go through; For the driver it didn’t show ET-2850 as an option anymore, but “recommended” the ET-2840 driver. I went with that and the printer now shows up on the printer manager, but all it will do is feed sheets of blank paper. It also doesn’t allow duplex printing as an option (which I would really like to have). Not sure if that is “progress” or not!

where would I find the IPP Everywhere/universal driver? I don’t see it on any of the lists of options. Also, “document scanner” now recognizes the scanner, but won’t connect.

OK; I found the IPP Everywhere/universal driver and tried that; on the “test page” the printer just endlessly fed sheets of blank paper. printing other documents doesn’t even do that. Still can’t connect to the scanner.

You can try installing epson-inkjet-printer-escpr driver from AUR which does contain drivers for ET-2850

You can enable AUR in software center from PreferencesThird Parties, but remember that AUR packages are not official, provided by users as-is. You may want to see: [Need-To-Know] About Manjaro and AUR

I would also recommend enabling avahi-daemon service (for discovering printers) if you are trying to install the printer via network and not via cable.

After that you should be able to normally (via system setting GUI / CUPS) add a printer (at least I was able to install my EPSON printer) - I’m on KDE Variant. But remember to choose correct driver which should now be available.

Optionally you can configure the printer directly in cups by visiting http://localhost:631/admin (you login with your system credentials)

Progress at last!
The printer is working (color & duplex printing). Still can’t connect to the scanner; any idea how to fix this?

Via network? avahi-daemon service enabled and running + skanlite/skanpage should work

Via USB? Try installing ipp-usb

Additionally, you may want to install sane-airscan to support… airscan (not required)

I’m using USB. I installed ipp-usb and sane-airscan,; ‘image scanner’ worked once (after failing several times and locking up the scanner once -couldn’t even shut it down, had to unplug it!). I tried it again and it said “unable to connect to scanner”.
‘Image scan for linux’ says “could not send command to scanner. Check scanner status”.
If I try to initiate a scan from the printer, it just says “invalid”

Update; I discovered that “document scanner” has a menu that shows detected scanners, and the Epson is listed twice; If I select the second listing, it works. A little awkward, but I can live with that. I guess the issue is solved.
Thanks for your help and patience!
“Plug & Play”… should be “Plug & Pray”