Not getting updates for AUR packages

I’m currently using firefox-beta-bin(98.0b3). When I check AUR the latest build is 98.0b6. But I can’t seem to update the package from pamac. When I run pamac checkupdates -a it says “Your system is up-to-date”. Check for update in Enable AUR option is enabled in pamac. I’ve also tried to manually refresh database through pamac. But nothing seemed to help so far.
I’ve checked another package out of curiosity that is not installed in my system google-chrome-dev. The current version for that package in AUR is 100.0.4892.0 but when I search through pamac I get 100.0.4878.0.

Some help would be appreciated.

1 Like

This is a known bug. You can use yay to install/update packages from AUR for the time being:

sudo pacman -S yay
yay -Syyu

AUR is for Arch as a storage space for buildscripts to build Archlinux packages.

If was never meant to be a repository for a third party distribution.

When users percieve AUR as an extra repository and endlessly is checking for updates to their favorite scripts it will bring AUR to it’s knees.

Please use AUR responsively

1 Like

I have a quick comprehension question: Wouldn’t the command pacman -Syu yay be a better choice?

To install a software package, the basic syntax is pacman -S packagename. However, installing a package without updating the system will lead to a partial upgrade situation, so all the examples here will use pacman -Syu packagename which will install the package and ensure the system is up-to-date.

:link: Pacman Overview - Manjaro

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.