Not executing .x86_64 files

I’m having trouble running files that are .x86_64.
To be more specific every time I run a file of this type the execution starts but soon after the application crashes.
I discovered this problem after trying to play blasphemous through steam and every time the game started it crashed along with steam, and apparently the game executable is a .x86_64 file.
I’ve tried running other files with the same extension and they all happen to have the same issue.
I saw somewhere that I had to grant an executable file permission, I did that and the problem still persists

Have you tried executing the file in a terminal to look for errors?

Such files are not necessarily executable. You can verify such file

file <filename>


 $ which micro

 $ file /usr/bin/micro
/usr/bin/micro: ELF 64-bit LSB pie executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/, BuildID[sha1]=ea426b163d405bd3a7e5c0234fe256392f2f9e23, for GNU/Linux 4.4.0, stripped

I know next to nohting about gaming but what I think I know is that a lot of games is using a wine layer (bottle or prefix) to run and the when the games exefile fails like you describe - it could point to the used wine bottle is 32-bit rather than 64-bit.

And before you ask - I have no extensive experience with wine either :slight_smile:

1 Like