Not connecting to the wifi

Hello folks!
After reinstalling the Manjaro KDE, my laptop is not connecting to the university wifi (wpa/wpa2 enterprise). My laptop is connecting to other wifi with no issues. When I enter the username and password (100% correct), after some time the popup windows is appearing asking to enter the password (again and again). I can connect to the wifi with my android phone. (There is no issue with the wifi).

I have already contacted with IT department, I am not in the blocklist.

System info:

  Kernel: 6.1.44-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.7 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: Victus by HP Laptop 16-d1xxx v: N/A
    serial: <superuser required>
  Mobo: HP model: 8A26 v: 34.55 serial: <superuser required> UEFI: AMI
    v: F.07 date: 04/20/2022
  ID-1: BAT0 charge: 55.2 Wh (88.2%) condition: 62.6/70.1 Wh (89.3%)
    volts: 17.6 min: 15.4 model: HP Primary status: charging
  Info: 12-core (4-mt/8-st) model: 12th Gen Intel Core i5-12500H bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.1 MiB L2: 9 MiB
    L3: 18 MiB
  Speed (MHz): avg: 2659 high: 3100 min/max: 400/4500:3300 cores: 1: 846
    2: 3100 3: 864 4: 3100 5: 3100 6: 3100 7: 3100 8: 3100 9: 3100 10: 539
    11: 3100 12: 3100 13: 3100 14: 3100 15: 3100 16: 3100 bogomips: 99568
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile]
    vendor: Hewlett-Packard driver: nouveau v: kernel arch: Ampere
    bus-ID: 01:00.0
  Device-3: Quanta HP Wide Vision HD Camera driver: uvcvideo type: USB
    bus-ID: 3-6:2
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2 driver: X:
    loaded: modesetting dri: iris gpu: i915 s-res: 1920x1080
    resolution: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  API: ALSA v: k6.1.44-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.77 status: off
  Server-3: PulseAudio v: 16.1 status: active
  Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
    vendor: AzureWave driver: mt7921e v: kernel bus-ID: 05:00.0
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 06:00.0
  IF: eno1 state: down mac: <filter>
  Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
    bus-ID: 3-7:3
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 238.47 GiB used: 44.78 GiB (18.8%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD PC SN810
    SDCPNRY-256G-1006 size: 238.47 GiB temp: 32.9 C
  ID-1: / size: 233.38 GiB used: 44.78 GiB (19.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 33.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 1996 fan-2: 2204
  Processes: 314 Uptime: 5h 25m Memory: total: 16 GiB note: est.
  available: 15.29 GiB used: 4.6 GiB (30.1%) Init: systemd Compilers:
  gcc: 13.2.1 clang: 15.0.7 Packages: 1277 Shell: Zsh v: 5.9 inxi: 3.3.29

Hello @Devalyus,
Maybe this helps:

Thanks you for the answer. I will try and get back…

It’s eduroam, right? You have to set the options correctly.

MSCHAPV2 and PEAP are important.

I have tried to replicate the case in this thread [SOLVED] Cannot connect to the special Wi-Fi router / Newbie Corner / Arch Linux Forums
But it does not help(

Yeah MSCHAPV2 and PEAP are selected

Guys actually this error has been for quite some time especially with wpa enterprise with no certificate."unsupported_protocol"_error

Try setting phase1-auth-flags to 32 as described there.

1 Like

Hello! Thanks for the reply. I am not near the uni wifi now, tomorrow I will check.

@MrLavender Thank you for your help. It worked.
Setting phase1-auth-flags to 32 worked for me.
For future users:

  1. Go that wiki arch page.
  2. Follow the instructions
  3. Do not forget to restart NetworkManager service))

Thank you guys for all! Cheers!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.