Not being able to add my hard drive to steam

Hi so I’m kinda new to Manjaro and I was trying to add my hard drive as a game drive since my SSD isn’t big enough but as i added it to steam it just wont add it doesn’t spit out any errors at all (also my drive is ext4) been looking for hours but cannot find anything that could fix this if anyone could help me I would really appreciate it

I’m assuming you are using a USB HD.

Manjaro normally adds external devices to /run/media/username have you tried looking there?

Yes i have looked there and it is there but when i add it into steam it just wont add it

Maybe Steam does not have the right permissions to manage the files on the folder. I changed permissions of the folder and that fixed it for me. If you want to change permissions and assuming you are on KDE Plasma, just open “Properties”, go to Permissions tab and check the option “Apply changes to all folder and contents” (might be written in another way, I don’t have an english setup here).

I hope it helps.

Also keep in mind, that steam library should be installed on a ext4 or other linux partition.

My first time where i try steam linux gaming was where i though i could share my NTFS Partition where i had a few Windows Games on it, but thats not really working… just evade it.


NTFS works with a caveat, I use it successfully with steam on manjaro. You just need to add uid=$YOURUID,gid=$YOURGID to the mount point in /etc/fstab. This means your user needs admin rights to the steam drive on ntfs. So it may not be ideal, but it works.