Not able to save files to external hard drive in Manjaro

I am not able to save files to my external hard disk in Manjaro and also when I set my default file locations on to my external drive they were reset to the default ones after I rebooted.
I am using a Manjaro + Win10 dual boot, and I usually store my files on my HHD instead of the SSD I boot from.
I read somewhere that this is a permission issue as applications do not have permissions to acess the external drive.
How do I fix this ?
(PS: I am a Manjaro (technically linux) newbie so please try not to get triggered if this is a really stupid question)

Welcome to the forum. As you have mentioned that you dual boot with windows, please disable fast startup in windows. Control panel>Power options>Choose what closing the lid does>Uncheck fast startup checkbox>Apply settings
That may help. Also post the output of lsblk

I am pretty sure you can use the chmod 777 /pathtodrive command for this.

I have turned off fast startup and this was the output when I ran the lsblk command

loop0         7:0    0 164.8M  1 loop /var/lib/snapd/snap/gnome-3-28-1804/161
loop1         7:1    0  65.1M  1 loop /var/lib/snapd/snap/gtk-common-themes/1515
loop2         7:2    0  32.3M  1 loop /var/lib/snapd/snap/snapd/12883
loop3         7:3    0  55.4M  1 loop /var/lib/snapd/snap/core18/2128
loop4         7:4    0  74.4M  1 loop /var/lib/snapd/snap/p3x-onenote/128
sda           8:0    0 931.5G  0 disk 
└─sda1        8:1    0 931.5G  0 part /run/media/myname/DATA
nvme0n1     259:0    0 238.5G  0 disk 
├─nvme0n1p1 259:1    0   260M  0 part /boot/efi
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0 139.7G  0 part /run/media/myname/Windows
├─nvme0n1p4 259:4    0   648M  0 part 
└─nvme0n1p5 259:5    0  97.9G  0 part /

The DATA drive is where I usually store my files.

With lsblk -f we can see also what filesystem that DATA has. If is NTFS, then you need to use the ntfs-3g package. Also i would recommend avoid to automount it trough fstab, and instead mount it via File Manager, but that is up to you.
More about NTFS-3G - ArchWiki

If is a Linux filesystem, then take ownership of that partition.

My HHD is still using NTFS, also to note that my system has the NTfs-3G package installed to it already.
I have added the drive to automount in fstab now but the problem still persists. When I try to make a file in LibreOffice (or any program in general) I get an error message while saving the file to the external drive saying

Object not accessible.
The object cannot be accessed
due to insufficient user rights.

So how do I grant these “user rights” to the programmes ?

Share that entry in fstab with us, but i hope you read the link i shared to the wiki above … Also, hope you turned off the required things in Windows. Also, is the search forum not working ?

1 Like

This is my fstab entry

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
#data drive automount (dev/sda1)
UUID=C028D53E28D5345E   /run/media/myname/DATA ntfs    defaults        0       0

And thanks for the link I’m sorry I didnt get the idea to look for a possible solution on the forum.

This was the most important

if you read that, you would know why this

is wrong. Has to be ntfs-3g

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.