Not Able to Record Screen with OpenGL compositor

I am running Manjaro KDE Plasma on my HP Pavilion 15t cs200. It has an i7 8565U processor, Intel UHD Graphics 620.
For screen recording, I have tried both OBS studio and SimpleScreenRecored. The issue is, my recorded video has a completely flickering recording. You can take a look below.
My compositor is OpenGL 2.0. To fix this issue, I have to switch to xRender compositor. But, that makes my menu bar, notification bar, start menu, literally everything transparent. Due to this, I cannot use xRender as the default compositor.
Using OpenGL 2.0 or 3.1 does not help me with screen recording. Please help me.

@Ernest1337 If you could help to solve this issue, it will be very helpful for me. Due to this, I have to switch to xrender for screen recording and then have to revert back to OpenGL 2.0.

Just to clarify, your issue is the flickering?

yes, the flickering issue while using OpenGL 2.0 or 3.1 during screen recording.

Can you post output of inxi -b?

[amartyasinha918@amartya-hp ~]$ inxi -b
Host: amartya-hp Kernel: 5.10.34-1-MANJARO x86_64 bits: 64
Desktop: KDE Plasma 5.21.4 Distro: Manjaro Linux
Type: Laptop System: HP product: HP Pavilion Laptop 15t-cs200
v: Type1ProductConfigId serial:
Mobo: HP model: 84C0 v: 15.32 serial: UEFI: Insyde v: F.23
date: 12/25/2020
ID-1: BAT0 charge: 33.0 Wh (98.8%) condition: 33.4/33.4 Wh (100.0%)
Info: Quad Core Intel Core i7-8565U [MT MCP] speed: 670 MHz min/max: 400/4600 MHz
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.11 driver: loaded: intel unloaded: modesetting
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.0.3
Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
Local Storage: total: 931.51 GiB used: 379.17 GiB (40.7%)
Processes: 236 Uptime: 8h 24m Memory: 15.53 GiB used: 2.77 GiB (17.8%) Shell: Bash
inxi: 3.3.04

I’m suspecting that that’s an issue with either kwin, graphics drivers (mesa) or Xorg.

But as you said, it works under xrender, this may indicate a problem with opengl (mesa).

Did the issue appear suddenly of was it there from the beginning?

From the beginning. I am not getting any issue while using my laptop. Only the recorded video is affected

also, can you post you obs recording settings? (settings>output>recording)

I have tried recording format as mp4 as well as mkv. But, the problem remains the same in both format.

can you set the output mode to advanced and show me the encoder options (what can you select other than software x264)

have you tried recording using VAAPI hardware encoder?

yeah, but the problem is the same.
actually, the problem is related to OpenGL as the recording of other screen recorders are also flickering.

Ok, try changing the compositor tearing prevention setting in the kde settings from “Automatic” to any other and see if any of them help.

I tried all of them, but none helped me. Btw thanks for the effort. Looks like I’ll have to always switch to xRender before recording screen.

No problem, have a nice rest of the day! :slight_smile: