Not able to login with UI since last update/reboot - KDE Plasma - Xorg - free video-linux driver


I’ve been trying to fix this issue since more than a week now, on my own. I couldn’t fix it by -

  • reading similar (more than a dozen) posts on this and other forums (manjaro, arch linux, kde, so, etc) and trying the suggestions provided in each
  • installing nvidia (non-free) drivers and then removing them
  • trying different free drivers - modesetting, vesa, linux
  • trying a newer kernel versions (original was 414; now using 515)

Now, I’m using live usb version of Manjaro on the same machine.
With live usb, if I select proprietary drivers, I get the same symptom as with my system - system boots up, most services start and when the boot sequence tries to launch the GUI, the machine hangs. If I select free drivers with live usb, GUI works without any issue.

With my system (on hdd), machine boots and gets stuck at black screen, never reaching the login screen. I’m able to switch to TTY. This is how I’ve been able to try out all the steps I’ve listed above.

I’ve gone through both (hdd and live) setups and tried to compare versions of xorg, kde, video-drivers, kernel, etc but have not found any difference among the two systems.

My goal is to recover the system as I know that other than GUI part, my system is still functional. I don’t have anything critical on the system. So, in worst case scenario, I can wipe it and re-install a linux distro, but I’d prefer to recover the current instance and may be learn a thing or two about Linux GUI components in the process.

Thanks for your help. Please let me know what info will help you to help me and how I can collect it (commands to run).

System: Sony VAIO laptop - model: vpcf120fd - about 10 years old.
Graphics card: nVidia GT218M [GeForce 310M]

# uname -a
Linux manjaro 5.15.6-2-MANJARO #1 SMP PREEMPT Sat Dec 4 11:11:58 UTC 2021 x86_64 GNU/Linux
[manjaro /]# mhwd-kernel -li
Currently running: 5.15.6-2-MANJARO (linux515)
The following kernels are installed in your system:
   * linux414
   * linux515
[manjaro /]# mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

xorg logs -
location of this file on my system - /home/username/.local/share/xorg/Xorg.0.log

# grep EE /home/manjaro/Documents/Xorg.0.log                                                                                                                                           
[  2529.591] Current Operating System: Linux vaio-manjaro 5.15.6-2-MANJARO #1 SMP PREEMPT Sat Dec 4 11:11:58 UTC 2021 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2529.718] (EE) VESA(0): Cannot read int vect
[  2529.718] (EE) Screen(s) found, but none have a usable configuration.
[  2529.718] (EE) 
[  2529.718] (EE) no screens found(EE) 
[  2529.718] (EE) 
[  2529.718] (EE) Please also check the log file at "/home/username/.local/share/xorg/Xorg.0.log" for additional information.
[  2529.718] (EE) 
[  2529.721] (EE) Server terminated with error (1). Closing log file.
[manjaro /]# journalctl --boot=0 --system --priority=3
-- Journal begins at Tue 2020-08-11 15:25:22 EDT, ends at Sat 2021-12-11 17:40:46 EST. --
-- No entries --

output of inxi --admin --verbosity=7 --filter --no-host

Run ls -l /usr/lib/X* and see if all permissions are correct.

In my case the result is :

-rwxr-xr-x 1 root root 2498816 nov 11 00:25 /usr/lib/Xorg
-r-sr-xr-x 1 root root 17368 nov 11 00:25 /usr/lib/Xorg.wrap

drwxr-xr-x 2 root root 4096 nov 5 2020 bindings
-rw-r–r-- 1 root root 3538 sep 27 2020 system.mwmrc

Here is my output -

[manjaro /]# ls -l /usr/lib/X*
-rwxr-xr-x 1 root root 2498816 Nov 10 18:25 /usr/lib/Xorg
-r-sr-xr-x 1 root root   17368 Nov 10 18:25 /usr/lib/Xorg.wrap

Did you try with kernel 5.10 version?

I did not.

I’ve tried 414 and 515 so far.
Live USB is also on 515 and GUI is working with that version.

If there is something particular about 510, I can give it a shot as well.

Its Lts version and work well.
With latest version of 5.15 someone reported unability to start graphic server.

Try creating /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf file with .

Section “ServerFlags”
Option “IgnoreABI” “1”

With propietary drivers.


Tried v510. Same results -
on boot, I get black screen with two lines of text:
starting version 249.7-2-manjaro
/dev/sda1: clean, NNN files, NNN/NNN blocks.

System never advances from this point. I need to TTY and then reboot.

Added the ignoreabi.conf file and rebooted with v510.
Still not seeing login screen GUI.

[manjaro /]# grep EE /home/username/.local/share/xorg/Xorg.0.log
[    88.294] Current Operating System: Linux vaio-manjaro 5.10.83-1-MANJARO #1 SMP PREEMPT Wed Dec 1 14:46:38 UTC 2021 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    88.334] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    88.334] (EE) Failed to load module "vesa" (module does not exist, 0)
[    88.518] (II) Initializing extension MIT-SCREEN-SAVER
[    88.529] (EE) 
[    88.529] (EE) Backtrace:
[    88.529] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x89) [0x55f248b13059]
[    88.529] (EE) 1: /usr/lib/Xorg (0x55f2489c3000+0x15ae79) [0x55f248b1de79]
[    88.529] (EE) 2: /usr/lib/ (0x7fef8c1b2000+0x13870) [0x7fef8c1c5870]
[    88.529] (EE) 3: /usr/lib/Xorg (xf86OptionValue+0xb) [0x55f248b2a3db]
[    88.529] (EE) 4: /usr/lib/xorg/modules/extensions/ (0x7fef8b634000+0x34c11) [0x7fef8b668c11]
[    88.530] (EE) 5: /usr/lib/Xorg (InitExtensions+0x89) [0x55f248a0bd29]
[    88.530] (EE) 6: /usr/lib/Xorg (0x55f2489c3000+0x3c35b) [0x55f2489ff35b]
[    88.530] (EE) 7: /usr/lib/ (__libc_start_main+0xd5) [0x7fef8c008b25]
[    88.530] (EE) 8: /usr/lib/Xorg (_start+0x2e) [0x55f248a0075e]
[    88.530] (EE) 
[    88.530] (EE) Segmentation fault at address 0x100000011
[    88.530] (EE) 
[    88.530] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    88.530] (EE) 
[    88.530] (EE) 
[    88.530] (EE) Please also check the log file at "/home/username/.local/share/xorg/Xorg.0.log" for additional information.
[    88.530] (EE) 
[    88.533] (EE) Server terminated with error (1). Closing log file.
[manjaro /]# cat /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf 
Section "ServerFlags"
  Option "IgnoreABI" "1"
[manjaro /]#

Do you have installed xf86-video-nouveau package or nvidia propietary drivers ?

AFAIK, I don’t have any proprietary video driver installed. But I’m not certain.

See if this answers your question?

[manjaro /]# pacman -Q | grep video
xf86-video-amdgpu 21.0.0-2
xf86-video-ati 1:19.1.0.r9.g5eba006e-2
xf86-video-intel 1:2.99.917+916+g31486f40-2
xf86-video-nouveau 1.0.17-2

Ignoreabi option only works with propietary driver.

mhwd -lh -d

16: PCI 100.0: 0300 VGA compatible controller (VGA)
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GT218M [GeForce 310M]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0a75 "GT218M [GeForce 310M]"
  SubVendor: pci 0x104d "Sony Corporation"
  SubDevice: pci 0x9067 
  Revision: 0xa2
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xe2000000-0xe2ffffff (rw,non-prefetchable)
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xe0000000-0xe1ffffff (ro,non-prefetchable)
  I/O Ports: 0xd000-0xdfff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 27 (253555 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000A75sv0000104Dsd00009067bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Attached to: #13 (PCI bridge)


As you can see, I’ve GeForce 310M. Last year, I saw some posts mentioning that Manjaro had dropped support for this and similar devices. At that time, I had removed the nvidia drivers. I’ve been able to use Manjaro for past one year without this current issue.

see post - dropping-all-legacy-and-older-nvidia-drivers/36338 (Sorry, can’t post links yet)

Did you try this ?

I don’t want to use non-free drivers.

I’m confused on how the live usb version is working without those drivers and why I’d need those drivers only for the installed version of Manjaro.

BTW - Yes I’ve tried the process listed in that post. It makes the situation even worse, as with that legacy driver even tty resolution becomes something like 860x640.

PS: I don’t use this machine for gaming, etc. So just basic visuals (GUI) is what I need. No hw acceleration, CUDA, etc is needed to work.

Read at this and try with kms.
Maybe this fix the issue.

First of all, thanks a lot for taking time to try to help me.

I read through the wiki article and tried a few things:
i. Installed lib32-libva-mesa-driver 21.2.5-1
ii. Added nouveau module to /etc/mkinitcpio.conf

Still no progress.

One other thing -
Even if I remove /etc/X11/xorg.conf.d/30-nvidia-ignoreabi.conf I’m still getting Segmentation fault error in xorg logs.
When I started, I’s getting no screens found errors only.

Is there a way to find what module is failing to load and what the root cause is? I’m trying several solutions without understanding the underlying problem.

In my system with intel card if i run pacman -Q | grep xf86
it returns:

lib32-libxxf86vm 1.1.4-2
libxxf86vm 1.1.4-4
xf86-input-evdev 2.10.6-3
xf86-input-libinput 1.2.0-2
xf86-input-synaptics 1.9.1-3
xf86-input-wacom 0.40.0-2
xf86-video-intel 1:2.99.917+916+g31486f40-2

try in your system removing unused xf86-video* packages .
I don´t know what is failing either to.

There is another topic in progress in parallel - Every Update breaks my configuration - #10 by alven

Even though not same, but it gave me a hint.

I did

$ sudo pacman -Q | grep nvidia 
mhwd-nvidia 495.44-5
mhwd-nvidia-390xx 390.144-1
mhwd-nvidia-470xx 470.86-3

Then I removed mhwd-nvidia-304.xx-x

sudo pacman -R mhwd-nvidia-304.xx-x

Rebooted, and voila - back to GUI :slight_smile:
It looks like even though I removed all the nvidia video drivers, somehow this package stayed installed.

Thanks @ddns for your help.

1 Like

That’s ‘great’, congratulations !!!