Normal boot stuck, but via bios it work

Hello everyone! I’m new here on Manjaro forums. Been using Manjaro and Mint for a few months now.

The problem:
If I use normal grub to start Manjaro it gets stuck in MB splash-screen. But, if I am to go into Bios and then chose Manjaro from the boot override, which brings me to Manjaro boot (I’m not sure exactly what it is, but this looks different than normal grub options) and when I chose normal Manjaro there it works fine. Which is where I’m typing from now.

Mint works as it should, so I doubt it’s hardware issue.

Only thing I’ve seen when searching for a similar problem is people get requested to reinstall graphic drivers. First thing I tried.

I typed the following:

journalctl --boot=-1 --priority=3 --catalog                                                                                                                                                                      INT ✘  50s  
apr 09 15:13:58 Zellogi-PC kernel: 
apr 09 15:13:59 Zellogi-PC kernel: EDAC sbridge: CPU SrcID #0, Ha #0, Channel #0 has DIMMs, but ECC is disabled
apr 09 15:13:59 Zellogi-PC kernel: EDAC sbridge: Couldn't find mci handler
apr 09 15:13:59 Zellogi-PC kernel: EDAC sbridge: Failed to register device with error -19.

Which made me try disconnecting all USB devices.
I also just noticed that I didn’t get any error messages today with the above command.

Using journalctl --boot=-1 didn’t seem to show anything of use.

Since I’m fairly new to Manjaro, I’m not sure where to go from here. Is there another log I can find to make sense of this? Can I find a grub log somewhere maybe? Since it could be the issue?

Kernel version I’m running atm is LTS 5.15.28-1. (tried older versions with no fix)

Edit, adding below:

inxi --admin --verbosity=7 --filter --no-host --width                                                                                                                                                     INT ✘  1h 33m 36s  
  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=4ff8bc97-fce6-406b-b5b1-1f676f054291 rw quiet apparmor=1
    security=apparmor resume=UUID=3d51a1ac-5c9e-48aa-95e3-85a7776ef0f9
  Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: X79-UD3 v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F20 date: 03/19/2014
  Message: No system battery data found. Is one present?
  RAM: total: 15.54 GiB used: 7.27 GiB (46.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-3820 bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2D (45) stepping: 7 microcode: 0x71A
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 10 MiB desc: 1x10 MiB
  Speed (MHz): avg: 1822 high: 2183 min/max: 1200/3800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1856 2: 2183 3: 1781
    4: 1648 5: 1718 6: 1920 7: 1513 8: 1963 bogomips: 57616
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cx16 cx8 dca de ds_cpl dtes64 dtherm dts epb ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce
    md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdtscp
    rep_good sep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 02:00.0 chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6400x2520 s-dpi: 91 s-size: 1786x703mm (70.31x27.68")
    s-diag: 1919mm (75.57")
  Monitor-1: DP-0 pos: primary,2-2 res: 2560x1440 hz: 60 dpi: 90
    size: 725x428mm (28.54x16.85") diag: 842mm (33.15") modes: N/A
  Monitor-2: DVI-D-0 pos: 3-4 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  Monitor-3: HDMI-0 pos: 1-3 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  Monitor-4: HDMI-1 pos: 3-1 res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 510.54
    direct render: Yes
  Device-1: Intel C600/X79 series High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1d20
    class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 02:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: GYROCOM C&C UAC1 DAC type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.3:4 chip-ID: 1852:5110
    class-ID: 0102
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel 82579V Gigabit Network vendor: Gigabyte driver: e1000e
    v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 4.78 TiB used: 2.48 TiB (51.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 033 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000DM000-1F2168
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5900 serial: <filter> rev: CC54 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%)
    used: 269.1 GiB (29.7%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 4ff8bc97-fce6-406b-b5b1-1f676f054291
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 5.4 MiB (1.8%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: NO_LABEL
    uuid: 016E-DDC2
  ID-3: /mnt/sdc raw-size: 3.64 TiB size: 3.58 TiB (98.40%)
    used: 2.22 TiB (61.9%) fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: 539d4efa-e4c2-4dd6-9a55-b7dadf667fcc
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 29.9 MiB (0.3%)
    priority: -2 dev: /dev/sdb3 maj-min: 8:19 label: N/A
    uuid: 3d51a1ac-5c9e-48aa-95e3-85a7776ef0f9
  ID-1: /dev/sda1 maj-min: 8:1 size: 238.47 GiB fs: ext4 label: N/A
    uuid: e1a494c1-a3ff-4b0b-b7da-53e24b7fe69d
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.3:4 info: GYROCOM C&C UAC1 DAC type: HID,Audio
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 110mA chip-ID: 1852:5110 class-ID: 0102
  Device-2: 1-1.5:5 info: Corsair Vengeance K70R keyboard type: Keyboard,HID
    driver: corsair,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 1b1c:1b09 class-ID: 0300
  Device-3: 1-1.6:6 info: Razer USA Naga Epic (Wired) type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 1532:001f class-ID: 0300
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 47 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 306 Uptime: 1d 5h 2m wakeups: 0 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1354
  pacman: 1348 lib: 400 flatpak: 0 snap: 6 Shell: Zsh v: 5.8.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.15

Boot when manjaro gets stucked, then boot via bios when its booting normally and run this command:
journalctl --boot=-1
then scroll via arrow down on your keyboard through the logs…
Also did it get stuck on a black screen?

No black screen. MB splash-screen, but no text underneath that usually is there on normal startups. Just the picture.

Checking it again and didn’t show much. A lot of detecting and starting stuff. No more than above error message.
I feel a little dumb, didn’t really understand the journactl command. Didn’t think about what the number etc really did. Now I do.

Anyway, back to the issue. From what I can see nothing still stands out. No failures or other error messages.

I won’t be able to do this until tomorrow. But I will start it up and let it sit, write the time down, and wait a few minutes so I can easier see what that startup that failed are saying. But atm I can’t really tell that something is being written for the failed startup. It ends with yesterday and then just seemingly normal boot.

I think I forgot to add, when it locks/freezes on the MB splash-screen both mouse and keyboard is without power. So only thing I can do is hit the reset or power button to continue on anything.

I’ll report back tomorrow on my finding

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

If the boot seems to get stuck,

you often get to a terminal for troubleshooting and for inxi with with CTRL+ALT+F2

i meant that you provide the last 20 entries from the command … and yes, wait when it freezes for at least 10 minutes… also doing force/hard resets is not good for your system, so before youre going to test the freezing, prepare your pc to cleanly reboot with this guide:

1 Like

Ok, after waiting 10 min on the freeze I did the <5 sec power button. Waited 5 more min and nothing. Pressed again and waited 5 min more. Had to use reset button (or 5> sec power button works too) to exit the freeze. And as I said in previous post no power to the keyboard or mouse, tried the alt/altgr SysRq just to be sure. And no other inputs work, like the ctr-alt-F2 (through F8).

And journalctl -listboot only shows today and yesterday. So no logs for the freeze. Did a check with yesterdays logs and it ends on the evening when I shut down the computer as normal. Nothing added after.

and if you run this command, and check if there are some errors:
sudo update-grub
also try to disable the login sddm screen:
system settings/ startup and shutdown/ login screen click on the behavior button and check automatically log in, then click apply
also check bios settings:

Firmware checklist for BIOS systems - if you are using bios

  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems - if you are using uefi

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot (if unable to boot from USB) - this option is only if you are dual booting with windows
sudo update-grub                                                                                                                                                                                                      ✔  8s  
[sudo] password for zellogi: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Linux Mint 20.3 Una (20.3) on /dev/sda1
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin

Did the system settings to auto login.
(I’ll update this after restart)

AHCI enabled on all disks. Legacy boot, Fast boot and Secure boot off. No RAID activated. Optane Memory and Rapid Storage Technology is something I couldn’t see, pretty sure it’s a feature I don’t have on this mb. (Gigabyte x79 ud3)
This is something I’ve had for a long time. Nothing changed in the last months.

i see that youre using mint, does it normally boots into mint? … also try switching kernels, go to system settings/ kernel, and install the 5.16.14-1, and the 5.10.105-1 then reboot and try booting with them

Yes, Mint works fine. No problems there. I already tried different kernels.

I was using mint for a few days/weeks. And now when I came back to Manjaro is when this happened. Before it was working fine.

when you in the login screen, try booting into TTY by ctrl + alt + f2 and type startx and check if it freezes

Try doing an update-grub in Manjaro because Mint might have screwed up something…

1 Like

This works fine.

@Fabby I did that just before. But done again.

I thought I might add:
When I launch the “Manjaro” option from Bios, it becomes “gnu Grub version 2.06~4~Manjaro”
While the normal grub that boots first is “Grub version 2.04”

I guess one workaround is to make the Manjaro grub start at boot. And just ignore the problem. But I would like to learn what caused it. And for others that might get inte this situation.

Manjaro requires Manjaro’s GRUB to boot properly. You need to use Manjaro’s GRUB to boot other systems. If you’re using your Mint’s GRUB to boot Manjaro, then it is probably why it breaks.

Set your Manjaro as first boot option in the BIOS/UEFI.

1 Like

Huh, you learn something every day. I didn’t think it’d be that picky.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.


However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.