NordVPN failing to build

Hi I’ve been trying to install nordvpn, and i keep running into this error. I am simply trying to install the client on my own machine.
I have tried to add my user to the docker group.

How can I fix this error?

I would love to understand the reason behind this error.

Cloning nordvpn build files...
Generating nordvpn information...
Checking nordvpn dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building nordvpn...
==> Making package: nordvpn 3.16.6-1 (2023-11-01T23:58:27 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found 3.16.6.tar.gz
==> Validating source files with sha256sums...
    3.16.6.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting 3.16.6.tar.gz with bsdtar
==> Starting prepare()...
You are not a member of the docker group. Docker is required to build the package.
Failed to build nordvpn

Looks like its telling you exactly what the problem is.

Are you a member of the group?


Though I will also mention that this package looks weird.

This kind of thing could be handled by the PKGBUILD itself.

Though is docker really required to build this?

Also worth noting - this is a very new submission.

I would personally use one of the more vetted packages with votes, etc … instead of this one by an unknown packager from a few days ago.

1 Like

I was also a bit confused about the docker part. It worked after a restart and starting the docker daemon.
nordvpn-bin was building fine, but said it was outdated and didn’t want to login. This one seemed like the best option in the package manager, but I guess it’s on me, since I thought this was a GUI client.

I ended up configuring the vpn through settings though.

Also give this fine tutorial a read:

docker ? please specify which custom script you are using.

When installing nordvpn the nordvpn-bin is the most common.

pamac build nordvpn-bin

When done

 sudo gpasswd -a $USER nordvpn


 sudo systemctl enable nordvpnd


1 Like

Thank you to summarize the process. This was very helpful !

Old Threads/“Necro-Bumping”