Noob Manjaro User with DisplayLink Problems

I looked through all of the posts and do not see the solve for my problem sadly. I am a student and really need the use of several screens so that I can have my text on one screen, notes on another and my IDE on another and so on. So, I would like to set up my DisplayLink driver in order to navigate through things easier. However, after reading and trying all of the suggestions, I keep getting this one screen blocker. I wonder if it is because this is yr 2022 and things have changed? Or I am just too much of a noob or overlooking something here. Here are the steps I followed prior to the screen I get:

Made sure evdi is installed

pamac build displaylink
systemctl enable displaylink.service
systemctl start displaylink.service

In which I get:

Job for displaylink.service failed because the control process exited with error code.
See "systemctl status displaylink.service" 

In which I get:
● displaylink.service - DisplayLink Manager Service
     Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/displaylink.service.d
     Active: deactivating (stop-post) (Result: exit-code)
    Process: 2537228 ExecStartPre=/sbin/modprobe evdi (code=exited, status=1/FAILURE)
Cntrl PID: 2537229 (run_as_users_wi)
      Tasks: 3 (limit: 9357)
     Memory: 1.7M
        CPU: 22ms
     CGroup: /system.slice/displaylink.service
             ├─2537229 /bin/bash /usr/bin/run_as_users_with_display systemctl --user --no-block stop displaylink-connect.service
             ├─2537234 /bin/bash /usr/bin/run_as_users_with_display systemctl --user --no-block stop displaylink-connect.service
             └─2537237 "[loginctl]"

Jun 23 10:16:27 CrystalLC systemd[1]: Starting DisplayLink Manager Service...
Jun 23 10:16:27 CrystalLC modprobe[2537228]: modprobe: FATAL: Module evdi not found in directory /lib/modules/5.15.48-1-MANJARO
Jun 23 10:16:27 CrystalLC systemd[1]: displaylink.service: Control process exited, code=exited, status=1/FAILURE

and “journalctl -xeu displaylink.service” for details.

In which I get:

zsh: command not found: journalctl-xeu

But then, I try to enter:

sudo nano etc/X11/xorg.conf.d/99-evdi.conf 

(in another suggestion on another site 99 was 20 and have tried both)

I get this screen where at the top it says:

GNU nano                                                                                                                              6.3

and below a bunch of options that I have no idea how or what to do with those. Again, sadly, noob. Such as ^G Help and so on.

Not sure but wonder if systemctl --user enable --now displaylink might be correct as per this

“2537229 /bin/bash /usr/bin/run_as_users_with_display systemctl --user --no-block stop displaylink-”

Sorry, I was studying, but saw your response and tried it. This is the result:

Failed to enable unit: Unit file displaylink.service does not exist.

I did double back at this point and re-asserted the line of code that gave no error:

systemctl enable displaylink.service

so somewhere down the road, it is not connecting between enabled and starting.

No what is saying is there is no display link service, perhaps because you set it up without user before.
“systemctl status displaylink”
If the above works then
“systemctl disable --now displaylink”
Then run my command in the above post.

Ok Robin, I did as you said, but:

systemctl status displaylink  :heavy_check_mark:
● displaylink.service - DisplayLink Manager Service
Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/displaylink.service.d
Active: activating (auto-restart) (Result: exit-code) since Thu 2022-06-23 18:08:12 PDT; 4s ago
Process: 501146 ExecStartPre=/sbin/modprobe evdi (code=exited, status=1/FAILURE)
Process: 501147 ExecStopPost=/usr/bin/run_as_users_with_display systemctl --user --no-block stop displaylink-connect.service (code=exited, status=0/SUCCESS)
CPU: 801ms
   ~  systemctl disable --now displaylink  3 ✘
Removed “/etc/systemd/system/”.
   ~  systemctl --user enable --now displaylink  :heavy_check_mark:  4s 
Failed to enable unit: Unit file displaylink.service does not exist.

With the Add/Remove tool provided by Manjaro, I did install the AUR for DisplayLink before doing all of this. Not sure what happened between then and now. Sorry for all the problems…

Still working on my Bachelor for Computer Science, so I am still learning the ropes with that and this.

I have solved the GNU page problem. It took some research but I was able to figure out how to use GNU. I am now connected to my DisplayLink monitor.

Please explain your solution, so others can find out, then mark this as solved.

I will as soon as I get my comp working again. After the fix I also did something with my monitor settings and that seemed to break my comp. I made a post about it here in the forums. If I can get to the notes I made, I can give a step by step.

Step 1: Check which kernel you have ex: I am using linux

to do this in Konsole type: uname-r to find what kernel you have:

Step 2: You may be prompted to pick which of several options of header you want to use. There were several for me and it is suggested that you use the first 2 digits of the kernel number. In my case that would make it 51, however, there was not an option for me to select 51, but there was an option for 515 so I chose that.

Step 3: In Konsole type in:

yay-S linux515-headers

Step 4: Make sure anything that you have open and unsaved at this point is saved just in case because you will need to reboot. Once you have saved all files, in Konsole type:


Step 4: In Konsole type:

yay -S evdi displaylink

Step 5: Just like Step 4, if you have any unsaved projects, save them now then in Konsole type:


Step 6: This next one gets a little tricky, after entering the command line in Konsole, you will be automatically directed to GNU editor. I say this before so that new programmers or people new to Manjaor/Linux will understand that this was not an error. In Konsole type:

sudo nano /usr /sha /X11/xorg.conf.d / 20-displaylink.conf

Step 7: Once the GNU editor has opened type:

Section “Device”

Identifier “DisplayLink”

Driver “modsetting”

Option “Pageflip” “false”


Step 8: When you are done entering Step 7 lines, hit Ctrl + x. Which will prompt you to save, say y for yes and save the file to 20-displaylink

Step 9: It may ask if you want to save an alternate file or something similar to this, say y for yes.

Step 10: this is a basic repeat of similar actions as step 6-8. In Konsole type:

sudo nano / usr / X11 / xorg.conf.d/ 20-evdidevice.conf

Step 11: In GNU type:

Section “OutputClass”

Identifier “DisplayLink”

MatchDriver “evdi”

Driver “modesetting”

Option “accelMethod” “none”


Step 12: Save as 20-evdidevice and then y for yes

Step 13: In Konsole type:


Step 14: Almost done activating DisplayLink. Just 3 more steps. In Konsole type:

systemctl start displaylink

Step 15: In Konsole type:

systemctl enable displaylink

Step 16: In Konsole type:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.