Non-linux steam games not launching

Steam play is enabled
Games on ext4
Steam-manjaro installed. Steam-native not installed.
I am not receiving an error.

Issue:
non-linux games sit in launching for 10+ mins, then go to “running”, however the game doesn’t actually launch, then it just goes back as if the game was never clicked.
Linux games (TF2, TW WH II, Rocket League, etc) launch and run fine (however Rimworld doesn’t see mods)

What I have tried (with updating and restarting):

  • I have tried several versions of Proton

  • I have tried to force a version in launch options

  • I tired prime-run %command% Prime isn’t installed:
    Warning: no matching device for config ‘video-hybrid-intel-nvidia-450xx-prime’ found!
    Error: config ‘video-hybrid-intel-nvidia-450xx-prime’ conflicts with config(s): video-nvidia-450xx

  • I have tried the rename dowser.exe trick

  • I have sworn at it and tried bribing it with beer and pizza

  • I have tried launching via Lutris

  • I have clicked Auto Install Proprietary Driver in Manjaro Settings Manager

  • I have uninstalled/reinstalled video-nvidia-450xx in Manjaro Settings Manager

    Running Steam on manjarolinux 20.1.1 64-bit
    STEAM_RUNTIME is enabled automatically
    Pins up-to-date!
    Steam client’s requirements are satisfied

Specs:
Kernel: 5.8.11-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.14.2 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: TUF Z390-PRO GAMING v: Rev X.0x
serial: <superuser/root required> UEFI: American Megatrends v: 2804
date: 04/15/2020
CPU:
Topology: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP
L2 cache: 9216 KiB
Speed: 800 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800
Graphics:
Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP104 [GeForce GTX 1070] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.9 driver: modesetting,nouveau
unloaded: intel resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
3: 1920x1080~60Hz
OpenGL: renderer: NV134 v: 4.3 Mesa 20.1.8

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-450xx            2019.10.25               false            PCI
 video-modesetting            2020.01.13                true            PCI
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

sudo mhwd -a pci nonfree 0300
> Skipping already installed config 'video-nvidia-450xx' for device: 0000:01:00.0 (0300:10de:1b81) Display controller nVidia Corporation GP104 [GeForce GTX 1070]

Which games are you trying to run?
Not all games are fully compatible with proton. You probably already know this but did you check protondb.com for reports on compatibility and user-side hacks / fixes for your games?
If all seems fine, try running steam in terminal and check the errors you get when the game fails to launch. I am just a user too, but I successfully have played and completed games like, witcher 3, batman arkham knight, hades, AC Odyssey etc. all on manjaro xfce.

1 Like

Can you try launching with lutris? You can then choose wine and proton versions from the menu. It will also give you a log from the terminal icon which will show you what is happening while launching and where it is hanging

Linux Games run fine. Only an issue with non-linux games. Most likely a driver issue.

From Lutris:
Running /usr/bin/steam steam://rungameid/718850
Initial process has started with pid 338164
Game is considered started.
Running Steam on manjarolinux 20.1.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client’s requirements are satisfied
/home/skaboomatude/.local/share/Steam/ubuntu12_32/steam steam://rungameid/718850
Game is considered exited.
Initial process has exited.
All children have exited.
Exit with returncode 0

https://www.protondb.com/app/718850

Seems like in the reports, the game launcher is broken. Instructions on fixing it is in one of the reports.
One report also says it is fixed but maybe try giving it a shot.

After much buggering with drivers I was finally able to get the prime drivers installed. Games are lunching. :slight_smile:

1 Like

Aah you figured it out? That’s great :-D. What was the problem with the drivers and how did you solve it? Just curious.