Nomachine stopped working after system update

After Updating from version 21.3.1 XFCE to 21.3.3 XFCE my noMachine client stopped working. Does anyone know what changed between those versions? Reverting back to 21.3.1 XFCE fixed my issue with noMachine.


nomachine appears to be an AUR package and as such probably needs a rebuild after the update. Also see

1 Like

Rebuild, uninstall, reinstall did not help. Is there a changelog for Manjaro?

You may need to look into the changelog of xfce :wink:

Stopped working in what way?

Any output if you run:


It starts, I select my connection, it connects and as soon as it tries to start the screen it dies. The server end gives connection and disconnection popups. No errors.

I tried to generate a stacktrace via gdb but I get a truncated output even with ulimits set to unlimited. NX logs also have nothing useful inside.

Removing all configs, reinstall, nothing worked until I reverted to the 21.3.1 snapshot

You mean like $HOME/.nx? Did you try connecting to some other system - does it also not work?
Also, it’s popular lately to try things with a new user, so you might want to do that as well.

Another thing…

Is this Manjaro .iso versioning? (At first I thought you are talking about xfce update itself.) This .iso versioning is meaningless and doesn’t tell anything on a rolling distro.
What matters is which packages got updated, so you might want to look into that.

I don’t seem to be the only one, See post “post-39247” at nomachine forums (For what ever reason I can’t post links)

Which package exactly is causing the issue I don’t know. I am hoping the people at noMachine will look into it.


@sschueller is right - I have the very same issue with Manjaro KDE and NoMachine. Stopped working after last system update, does not connect to any remote boxes (linux/win does not matter).

EDIT: Disabling hardware decoding by setting key Enable hardware accelerated decoding to disabled in $HOME/.nx/config/player.cfg fixed the problem for me.

Solution found here - forums nomachine com - topic - nomachine-client-disconnects-right-after-connection-in-latest-manjaro#post-39289 (sorry you can’t include links in your posts :nauseated_face: :face_vomiting:)