Node Red on Rock64

I have several issues while trying to implement Node Red on a Rock64 Running Manjaro/Plasma (which runs very well btw). Here’s where I’m at:
I wanted to creat a “mirror” of a home monitoring system that I’d created on a Raspberry Pi using MQTT and Node Red. I used the cli to install mosquitto, and Node Red according to instructions found online. The first thing I noticed is that If I go to “Add/Remove” software in the menu, Node Red doesn’t show up although it does show up in the Application Launcher. As far as running Node red, I can open the editor, and create or input flows, but don’t know how to get it to run as a service. For example, On the Raspberry Pi iteration, I can access my created dashboard by typing the upaddress of the Pi and port 1880/ui in a browser on the same network, and receive the dashboard and data, If I try on the iteration on the Rock64, the browser times out. So that makes me think Node Red is not running as a service. If I try to start it the same way as the Rpi, I get an error that says there’s no such command. I thought about removing all and starting over, that’s when I realized it wasn’t listed in the “add/remove” app. I’m not real savy in cli, so any help would be greatly appreciated.

Looking at the nodejs-node-red AUR package the service is called nodejs-node-red.service which you can enable at every boot and start with:

sudo systemctl enable --now nodejs-node-red

And see the service status with:

sudo systemctl status nodejs-node-red

Which is that command?

Moving to AUR, not a Desktop Environment problem

1 Like

In the Rpi environment the command is:
sudo systemctl enable nodered.service

Debian/Raspbian likely calls the service something like that. But in Manjaro/Arch, it’s nodejs-node-red.service like @Lolix said above.

I have reinstalled the OS and reinstalled node.js node red without using Snap after finding a warning on the node red site that if loaded using Snap, it would run in an isolated invironment, and might not be able to take advantagel of system resources outside the snap isolation (paraphrasing). After reinstalling everything, again, the same issues occured.
1 Node Red does not show up in the GUI menu as it does on the Rpi OS (debian)
2. if run from the cli, access through to the editor is available through a browser with address " But again when using Node Red Dashboard, it is not accessable from another browser on the network as it is with the Raspberry Pi Debian system. Also when the CLI terminal is closed the local host server is disconnected, where as on the Pi after providing the command "sudo systemctl enable nodered service, access to the dashboard is available to any browser on the network. I hope I explained correctly, because I’m not experienced beyond explaining the differences between what I see on the Rpi running a Debian distro , and the ROCK64 running Manjaro.

Update - At this point, I have installed a version of Ambian on Rock64 and ran the Node red install script written for debian distros. The Node Red does show up in the Apps menu. That’s as far as I’ve gotten.
Update. I have built a test flow on Node Red and was able to access the Dashboard via other browsers on the local network. The command to run it as a service worked as well. I could close the Terminal and the flow continued to run and update; i could close the browser instance where Node Red editing is done, and again, the flow continued to run and update. From this I take it that it works as it does on the Raspberry Pi.

The AUR pkgbuild re-package the nodejs module, while the node-red linux installer could install additional modules and could perform additional configurations


        [ ! "${response}" ] && read -r -t 15 -p "Would you like to install the Pi-specific nodes ? [y/N] ? " response
        if [[ "$response" =~ ^([yY])+$ ]]; then
            EXTRANODES="node-red-node-pi-gpio@latest node-red-node-random@latest node-red-node-ping@latest node-red-contrib-play-audio@latest node-red-node-smooth@latest node-red-node-serialport@latest"

The .desktop file is not present in the npm module, it is downloaded separately

sudo curl -sL -o /usr/share/applications/Node-RED.desktop 2>&1 | sudo tee -a /var/log/nodered-install.log >>/dev/null

Are you saying I should run the above command, Please excuse my ignorance. This is all quite new to me.

Another update:
I reinstalled Node Red from the GUI, by enabling AUR access in the ADD/REMOVE software app from the AUR repository…
This time Node Red did show up in the Launch area, but without the Node Red Icon. Instead there was an icon that resembled a “text” page.
It did run, and I was able to launch the editor in the Firefox browser. I then added the Node Red Dashboard module as well as several others I use frequently.
I then created a very simple flow that created a date and time clock that would appear on the Dashboard.
The Dashboard is accessible in 2 ways.

Firstly from the editor by clicking on an icon that opens a new local browser tab, which then displays the output of the flow. That worked.

Secondly from any browser which has access to the host ip address, (in my case on my lan) such as This is the user interface, and as such should present the Dashboard contents as a web page. This part did not work. The browser timed out waiting for a response.

After several warm and cold restarts, Node Red appeared to function as it should as a start up service, EXCEPT for the fact that the Dashboard is not accessible from outside the host. I’m not sure who should own this anomoly so I hope someone can steer it or me to the right direction. In the meantime, I guess I’ll have to revert back to Armbian to get my work done; thanks to all.

Sorry for not specifying, it wasn’t a suggetion, just a copy-paste of what the installer script is doing that the AUR pkgbuild don’t have

Use the platform that is most suited for your needs