Node Error, No File

So I tried installing node and npm using

sudo pacman -S nodejs npm

and it seemed to go through
but whenever I run node in the command line(or npm) to see if it works i get this:

node: error while loading shared libraries: cannot open shared object file: No such file or directory

I even tried using the GUI(Add/Remove Software) and pressed “reinstall” on there, still getting the above error.

Do I need to install anything else?

Welcome to the forum! :wave:

Make sure you’re fully up to date first.

that did the trick thank you so much

I guess I needed to fully update everything after I installed Manjaro from scratch

When you install a distro, you install a collection of pre-compiled packages in the ISO. These ISOs are only built so often, thus anything updated since the ISO was built will be out of date on a newly installed system. One of the first things you should do after installing any distro is check for updates.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.