No WLAN0 Interface on 8GB Raspberry Pi 4b with Manjaro Minimal?

I saw this thread with a similar problem, but on a Raspberry Pi 3b. I’m not experienced enough to know if the same solution will work on a 4b. :frowning: Wlan0 interface is not seen when running RPI4 minimal 20.12.1 image on RPI 3b+ - #2 by Darksky

iwd is enabled and active, but can’t find any interfaces. The wifi interface is not showing up when looking at inxi -Fazy, either.

uname -a:

Linux Nicole 5.10.76-2-MANJARO-ARM #1 SMP PREEMPT Thu Nov 4 10:38:27 CDT 2021 aarch64 GNU/Linux

You are not really giving any info on what you have installed there. WIFI
should work out of the box if you installed an image with a DE.

Sometimes people have to install crda and set their country code. Sometimes people have to change the WIFI channel in their router.

If you installed a minimal image then I am not sure what all needs done as I never use a minimal image. It may need some manual configs to get wifi going.

Sorry; I was in a hurry and ended up being more vague than I realized.

I am running Manjaro Minimal, so no DE is present.

This problem fixed itself when I did a clean install of the latest Minimal image from the website. I have no idea what was going on with it before.

Could it be you messed with it. :sob:

Almost certainly. :wink:

I just can’t remember what I did. I didn’t mess with the wifi at any point before that, and didn’t try plugging in any USB network adapters before that, either.

Best guess: when I disabled bluetooth I took the wifi interface out with it without realizing it. I haven’t disabled bluetooth on this reinstall, yet.

So, um. Don’t do that thing I did that I don’t know what I did. :stuck_out_tongue:

sudo systemctl disable attach-bluetooth
sudo systemctl disable bluetooth
sudo pacman -Rdd blueman


I was doing things in config.txt to turn off bluetooth. Pretty sure I killed the Wi-Fi in there. :stuck_out_tongue:

I do not mess with it in config.txt. If the attach-bluetooth is not disabled it can causes network issues and cpu usage trying to connect. I basically cut the head off the snake.

I assume removing blueman is to deal with that bug where it completely pegs at least one CPU core when the service is disabled?

Read my last post

1 Like


Not really sure blueman gets installed on a minimal image. It may not have a TUI.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.