No WiFi signal is shown after manjaro installation

I install manjaro few days back but after installation WiFi signal is not shown in my laptop. I looked for different solution but no thing work for me.
Here is inxi -Fxxza:

System:    Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/vmlinuz-5.9-x86_64 root=UUID=f4ab1c69-fc17-40b3-a68d-e0bc19887929 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Portable System: Dell product: Inspiron 3543 v: A09 serial: <filter> Chassis: type: 8 serial: <filter> 
           Mobo: Dell model: 03YYK8 v: A00 serial: <filter> UEFI [Legacy]: Dell v: A09 date: 01/29/2018 
Battery:   ID-1: BAT0 charge: 10.2 Wh condition: 19.5/41.4 Wh (47%) volts: 14.3/14.8 model: Samsung SD DELL XRDW256 
           type: Unknown serial: <filter> status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61) 
           stepping: 4 microcode: 2F L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17567 
           Speed: 2666 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 2669 2: 2495 3: 2535 4: 2494 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 

Nothing appears when i run 'rfkill list all’.
How can I solve this problem?

Welcome at the forum, @sagarbogati

Please, add the full output of

inxi -Fxxxza --no-host

In your post you skipped the most interesting part about your network! :grin:

Network:   Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Dell Wireless 1704 802.11n + BT 4.0 driver: N/A 
           modules: bcma, wl port: 5040 bus ID: 06:00.0 chip ID: 14e4:4365 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: 4000 
           bus ID: 07:00.0 chip ID: 10ec:8136 
           IF: enp7s0 state: down mac: <filter> 
           IF-ID-1: enp0s29u1u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 15.01 GiB (3.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: MBR 
Partition: ID-1: / raw size: 263.66 GiB size: 258.52 GiB (98.05%) used: 14.89 GiB (5.8%) fs: ext4 dev: /dev/sda3 
           ID-2: /boot raw size: 202.08 GiB size: 197.91 GiB (97.94%) used: 123.0 MiB (0.1%) fs: ext4 dev: /dev/sda1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 51.0 C gpu: nouveau temp: 49.0 C 
           Fan Speeds (RPM): cpu: 2378 
Info:      Processes: 210 Uptime: 1h 59m Memory: 3.76 GiB used: 2.14 GiB (57.1%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1224 lib: 337 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

You need an internet connection to proceed, either by bluetooth tethering or LAN.

Then update:

sudo pacman-mirrors -f && sudo pacman -Syyu

Afterwards, install broadcom-wl from AUR by

pamac build broadcom-wl

Afterwards, reboot.

1 Like

When i run pamac build broadcom-wl after update sudo pacman-mirrors -f && sudo pacman -Syyu error occured:
Error: target not found: broadcom-wl

At the moment, I can only recommend to search for the right package name and location by yourself, I’m not sure if it is in normal repo’s or AUR, please have a look here as well:
Broadcom wireless - ArchWiki

Maybe you can try with either broadcom-wl-dkms or linuxZZZ-broadcom-wl, where ZZZ is your kernel version number.