No wifi on Live USB (Broadcom wireless card!)

I’ve been trying to install Manjaro on a brand new laptop for 48 hours and keep hitting a brick wall as the installer cannot connect to wifi! Without displaying any errors, you’ll note.

After testing a lot of stuff (including other distros – no wifi there either!), I finally realized today (thanks to a passing comment on a forum) that the problem was with my wireless card… which is, yes, a Broadcom! Just my luck.

I’ve found a lot of people who said they had wifi working during install but that it failed afterwards. In my case, there’s no wifi right off the bat!

For reference, this is the ISO I downloaded:

(the regular 64 bit version, though I also tried with the minimal with same result)

On a side note, I burned it to a USB stick using Rufus.

So here are some of the things I’ve checked:

  • Downloaded ISO was not corrupt: hash checked out OK.
  • while I do have a wireless hotkey it has no light or other visual cue indicating whether it’s on or off… I did hit it a couple of times at random, but no change
  • rfkill list: displays “no” to both soft and hard blocked
  • I have no wireless icon in the taskbar, only Network Manager… but maybe this is normal?
  • the installed driver for wifi is bcma-pci-bridge… I figured I should replace it with b43, considering some of the answers I’ve found online, so I did “modprobe -r bcma” followed by “modprobe b43 allhwsupport=1”… when I checked inxi -Nazy again bcma was back???
  • pacman -Q | grep b43-fwcutter ==> shows as installed (version 019-3)
  • pacman -Q | manjaro-firmware ==> shows as installed (version 20160419-1)
  • pacman -Q | linux316-broadcom-wl ==> not installed (which is good, apparently!)

With all that said, here’s some information I got from inxi -Fzx… Sorry I can’t do a copy-paste since I have to use a different computer to connect to the internet. So I’m only including the basics. Let me know if you need anything else.

Kernel 5.8.16-2-MANJARO x86_64
Xfce 4.14.2

Acer laptop / Aspire ES1-431 V3.72
Motherboard: Acer Magellan_BA Type2

Dual Core Intel Celeron N3050

Intel Atom/Celeron/Pentium Processor x5-E8000
Display server: x11 1.20.9
Resolution: 1366x768 ~60Hz

Intel Atom/Celeron/Pentium Processor x5-E8000
Sound server: ALSA k5.8.16-2-MANJARO

Wifi device: Broadcom BCM4312 802.11b/g/n
Driver: bcma-pci-bridge
(there is also an ethernet device but I don't use it)

I hope someone can help me figure this out, as it’s driving me crazy! LOL

EDIT: I forgot to mention that since the OS never displayed a list of available wifi networks, I had to add mine manually. Password was correct, but I don’t know if I got everything else right. Still, I figure if something was wrong in there I’d at least get some sort of error message…

1 Like

Without exact PCI info of your WiFi I doubt people will be able to help, if at all possible…

Does this help?

lspci | grep -i broadcom
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)

Not if it is an onboard combined WiFi+Bluetooth chip.
Keep in mind that thread has an GUI tool to generate info automatically, and sometimes a problem is related to info you personally don’t think is needed.
That’s why it generates so generic info.
It’s of course your choice to help others help you better by providing more info as what you initially think is needed. :wink:

I’m not really sure what you need exactly… there’s A LOT of information on the chipset, and since I’m not on the same computer I unfortunately cannot do a copy-paste, I’d have to type everything manually and there are way too many lines! Is there anything specific that you’d need?

Aside from filename, license and description, “modinfo bcma” also provides srcversion, a ton of different aliases, depends (empty), retpoline (Y), intree (Y), vermagic, sig_id, signer, sig_key, sig_hashalgo, and signature.

On a side note, “lsmod | grep -i wifi” doesn’t bring up anything.

It does have both Wifi and Bluetooth, apparently.

It’s not for me personally, the total info can be useful for all those that can help.
The GUI log generator saves that info to a file which you can transfer to where you need, to be able to paste it here.

I’m trying to help you help others to help you better…

I know you are and I appreciate it :wink: Didn’t know about the log generator. Will look into that. Thanks.

BTW, just found on the ArchLinux wiki a note that the B43 driver requires “non-free firmware to function”… could this be it? Or is that Arch-specific?

EDIT: Looks like the manjaro-log-helper is not included in the Live CD, gah.

Today I bought a TP-Link dong (model TL-WN823NEU V2) as a temp solution as I need to get wifi running ASAP. It didn’t completely solve the issue, but there is some improvement.

When I connect the dong, a list of all the wifi networks now becomes available. Yay! Except, it never manages to connect, it keeps timing out. Hmmph.

Looking into it, I came across a number of solutions that involve replacing the default driver (rtl8xxxu) with a more specific one (rtl8192eu in my case). Problem is it’s on AUR repository… which I cannot access from that computer, since it won’t connect to the internet haha.

That said, I managed to download the .git file from here:

I placed it on a USB stick and with this was able to access it from the laptop where I want to install Manjaro.

But… I’m not sure what to do with it now?

I was trying to follow the instructions on this page, but it assumes an internet connection is available:

Hi, @desdenova

In order to find a proper wifi broadcom controller I suggest you could try and run the following command:
```yaourt broadcom-wl``

Maybe, whether you can install one of the drivers which suits your wifi card.
More information on this post in the old manjaro forum :

Hope it help, regards

I did solve it by buying a cable and restoring the router to default. the windows 10 installation was corrupt and disabled features that were resolved with updates Im using my seagate 1TB via usb through older alienware laptop. current issue is uncovering why the software rendering sernice is running from the bottom taskbar. and which drivers to update great OS btw hoping to increase firefox speed also :stuck_out_tongue:

1 Like