No wifi icons but adapter is connected to PC(kde plasma, linux 6.1.30-1)

Hello, there!
I need help, there are no Wi-Fi connections on my PC but wifi adapter is connected, I cheched lots of solutions but none of them helped. (Dell Optiplex 9030, Kde Plasma, dual boot with windows, linux 610, Tp-link adapter)

That’s not enough info, please post the output of
inxi -Fazy


Please copy and paste the terminal output here, using the </> button in the toolbar of the post editor. Screenshots are useless to us.

it says i cant include links

I am not talking about links. I am talking of copy/pasting the terminal output with the mouse, and how you can paste it into your post.

I`m pasting it(output from the terminal) but it actually says I cant use links

Then… remove the link from the pasted output, maybe? :roll_eyes:

Use the </> button in the toolbar of the post editor and paste the output between the two lines of three backticks each.

  Kernel: 6.1.30-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=90080a0c-6b44-4b4f-9496-374dd33b726f rw quiet splash
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 9020 v: 01
    serial: <superuser required> Chassis: type: 15 serial: <superuser required>
  Mobo: Dell model: 0XCR8D v: A03 serial: <superuser required> UEFI: Dell
    v: A07 date: 04/25/2014
  Info: model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell gen: core 4
    level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1562 high: 3193 min/max: 800/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3193 2: 800 3: 800
    4: 1455 bogomips: 25549
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Dell driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm
    built: 2013 ports: active: VGA-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0300
  Device-2: Realtek FULL HD 1080P Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.1:3
    chip-ID: 0bda:58b0 class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: VGA-1 model: HP E232 serial: <filter> built: 2015 res: 1920x1080
    dpi: 96 gamma: 1.2 size: 509x286mm (20.04x11.26") diag: 584mm (23")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel HD Graphics 4600 (HSW
    GT2) direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
    class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-3: Realtek FULL HD 1080P Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.1:3
    chip-ID: 0bda:58b0 class-ID: 0102 serial: <filter>
  API: ALSA v: k6.1.30-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: TP-Link 802.11ac WLAN Adapter driver: N/A type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.6:6 chip-ID: 2357:011f
    class-ID: 0000 serial: <filter>
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060
    bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 465.76 GiB used: 8.01 GiB (1.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000AAKX-75U6AA0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1H20 scheme: GPT
  ID-1: / raw-size: 232.57 GiB size: 227.87 GiB (97.98%) used: 7.98 GiB (3.5%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.3 MiB (26.4%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 160 Uptime: 1h 40m wakeups: 0 Memory: available: 3.74 GiB
  used: 1.24 GiB (33.3%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1159 libs: 350 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27

Is this from the live USB? Because kernel 6.1.30 is outdated. Also — although this doesn’t have anything to do with your problem — it says that you don’t have any swap. On a machine with only 4 GiB, you definitely need swap. But you can create a swap file later, if you want.

You mean installed by using live usb? no

No, I meant whether that output comes from the live USB or from the installed system. Because if that is your installed system, then it hasn’t been updated in a very long time.

Also… :arrow_down:

Hardware-1: Intel SATA Controller [RAID mode]

You must set your drive to AHCI in the UEFI/BIOS.

I was installing without wifi so I have an old kernel, it will be(probably) updated when I get internet connection

By the way, there are new ISOs out now. Maybe you’ll have better luck with those then. :arrow_down:

But keep your WiFi plugged in when you install this time.

I will try but when I was installing it I had same problem, wifi just wasnt showing(I installed Manjaro on my old laptop ans I didnt have such problem)

According to the information here: Device 2357:011f: NIC doesnt come up; Whitelist ? · Issue #102 · RinCat/RTL88x2BU-Linux-Driver · GitHub you need to install rtl8812au-dkms-git from the AUR.

1 Like

But that’s kind of difficult when…

  1. OP has no internet connection on that machine; and…
  2. OP’s system is not up to date.

OP probably also has no idea on how to install any package while offline. :face_with_diagonal_mouth:

Life without a LAN cable or phone tethering? :roll_eyes:

Apparently, because OP said… :arrow_down:

OP does have a laptop with internet — as I understand it, this would then be WiFi, but on that machine it works.

I was already wondering why OP was trying to use WiFi on what appears be a desktop machine — at least, according to the inxi output. But apparently WiFi is OP’s only option, and it only works on the laptop, not on the desktop.