No wifi icon on desktop and no connectivity

I recently tried to install i3 window manager and it caused some serious problems. I was unable to uninstall it with help from here Will not boot with plasma after botched i3 install but afterwards the internet did not work. Actually it did not work while i3 was still installed so I think this installation failure caused the issue, not removing i3. This i3 thing really screwed things up.

I read this post Unable to find any wifi connections and it seems I have the same behavior, on the same machine. But I do not get the errors when trying to reinstall drivers or restart the NetworkManager, but instead nothing happens. There is output with --verbose but I mean there is no change in the operation.

There is no wifi icon on the desktop and I can’t figure out how to get to the networking stuff. I’m new to Linux. From the desktop is there anything I can search? The only networking thing that comes up in Network Interfaces which I don’t know how to use. Where can I see network connections?

I’m not able to get inxi --admin --verbosity=7 --filter --no-host file since I cannot get the file from the pine book since it’s offline but I can give shorter responses (or is there a way I can get it from one machine to another w/o wifi? I don’t have a USB unfortunately). I’ll post anything else that could help here.

PS - I’ve tried several times to make sure this not the wi-fi kill switch Pinebook Pro - PINE64 by trying both what I think is on and also off, then rebooting. This does nothing.
PSS- The battery icon has also disappeared.

  1. First read this to put you in a good mood:

    [HowTo] become a Manjaro power user when you're a wizard at Windows but a N00b at Manjaro / Linux

  2. Now re-install your system as that’s going to be easier and faster than finding out what exactly went wrong on an offline machine.

  3. If you don’t like the above and would have a working Ethernet connection, the first thing to do would be to post an inxi --admin --verbosity=7 --filter --no-host --width because now we have zero information and won’t even know where to start to have a look to see what’s wrong, let alone suggest a solution.


So there’s been a delay and I’m finally doing this. I flashed a new micro SD with manjaro. The micro SD does not fit nicely in the slot and falls out, or gets stuck. Not sure if it’s the correct SD. For pinebook - Pic attached

But my question is how do I reinstall the OS? Booting with the SD in the slot, or in a usb adapater, does nothing. What commands do I need to make it boot from the SD? Where can I find instructions on how to do this?

@strit Can you point the user into the right direction or do you know who has a PineBook?

@chrisdel101 : reclassified to the ARM category…

A couple of things.

Booting from SD card works just fine. But the PBP can be a little picky about the SD card use, so if the one you have been trying does not work, you should try another. I’m using Sandisk Ultra cards here, which has always worked.

We released new images recently (20.12 release) so please download and try one of those.

What OS is on the eMMC?
If you boot from SD card with a different kernel than what’s on the eMMC, it can make battery, wifi and lots of other stuff unavailable, if the wrong kernel gets run. Example: You have kernel 5.7 on eMMC but run kernel 5.9 on SD card, if the kernel from the eMMC’s 1st partition gets loaded (can be checked with uname -a) you will not have access to kernel modules since the kernel versions don’t match.
The reason for this, is that there is a race condition between what boot partition gets used. Usually, it should take the SD card one, when you do a cold boot (no restart).


Thanks for the reply!!
So I’m getting the release from the link on the wiki, and it appears to be the 20.12 one Manjaro - Pinebook Pro XFCE

I burned it to SD using etcher. These files are on there after this process. Does this look correct? If not maybe I made a mistake there. That would then explain alot.

Also the SD card gets stuck in the port and I need to pry it out. This is not the behavior I’d expect. I’ve contacted support to see if this could alter the functionality. So it possible to use the SD with an adapter via USB to boot? It didn’t work and I’m not sure if it’s not possible, or it’s just not running correctly.

If it will work via USB by design, AND the files look okay on the SD, then I’ll go get a sandisk SD and try that.

Some of the sdcards you have to push in on it and it will release and pop out. You just can not pull it out. They are locked until you push in on the sdcard.

1 Like

Ahh U are right! It was so far in I thought it was stuck. If I push on it with a toothpick it come out.

That answers that question. Thanks!

So it was the SD. I was able to reinstall the OS with an Kingston SD.

But even now there is no wifi and ifconfig is not found.

I have an ethernet cable working now so at least there is internet to connect it. How can I trouble shoot?

I have a blank Network Connections panel- no listed connections. It allows me set up a wifi connection manually but I have no idea what to add here. How can I set this up manually knowing only connection name and PW?