No wifi after new install was turned off overnight

mhwd -l -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:00:02.0 (0300:8086:1912) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI  >

A good start might be

inxi -Fazy

(PS - looks like you are editing and adding more info, thanks, but please see the link for how to format)

inxi -v2
Host: dirk-10mls0se00 Kernel: 6.1.51-1-MANJARO arch: x86_64 bits: 64
Desktop: Cinnamon v: 5.8.4 Distro: Manjaro Linux
Type: Desktop System: LENOVO product: 10MLS0SE00 v: ThinkCentre M910s
Mobo: LENOVO model: 3106 v: SDK0J40697 WIN 3305065980651
serial: UEFI-[Legacy]: LENOVO v: M1AKT24A
date: 07/25/2017
Info: quad core Intel Core i5-6500 [MCP] speed (MHz): avg: 900
min/max: 800/3600
Device-1: Intel HD Graphics 530 driver: i915 v: kernel
Display: x11 server: [X.Org]( v: 21.1.8 driver: X: loaded: modesetting
dri: iris gpu: i915 resolution: 1920x1080~60Hz
API: OpenGL Message: Unable to show GL data. Required tool glxinfo
Device-1: Intel Ethernet I219-LM driver: e1000e
Local Storage: total: 370.78 GiB used: 9.33 GiB (2.5%)
Processes: 217 Uptime: 2h 38m Memory: total: 8 GiB available: 7.63 GiB
used: 2.43 GiB (31.9%) Shell: Bash inxi: 3.3.29 

Ok with some more info there, it does appear your wireless device is not recognized at all
(only the ethernet is listed):

Can you be sure it is not unplugged?
And/or can you provide any off-hand information about the device? is it internal or external? Do you happen to know the model? etc.

<BrosTrend 24G2 external. Sorry. I am having difficulty understanding the syntax for posting.>

And just to be clear … this was working previously?

As to the device - that looks like it has a USB connection of the device into the stand and then a USB running from the stand to the PC. Please try ‘re-seating’ (unplug and plug again) to ensure it is properly connected, also try switching the port it is using on the PC. And of course … do try turning it off and on again :wink:

After that bit of touching if its still missing then we might try looking a bit harder to look for it, such as lsusb, and/or give other kernels a shot. Maybe 5.15.

For posting code you may use the button at the top of the text window </> … or use 3 backtics like so:


Yes it was working perfectly until I did the post install upgrade. I will replug and turn system off and on again.

,No difference What should I query in the terminal?

You may check with


Which should list all USB devices.

Of course, on the off chance there is an issue with the device itself, it may be prudent to check if it works on any other system (if one is available).

Bus 002 Device 002: ID 0781:5591 SanDisk Corp. Ultra Flair
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 17ef:6099 Lenovo Lenovo Traditional USB Keyboard
Bus 001 Device 004: ID 0bda:b812 Realtek Semiconductor Corp. RTL88x2bu [AC1200 Techkey]
Bus 001 Device 003: ID 07fd:000b Mark of the Unicorn M4
Bus 001 Device 002: ID 17ef:608d Lenovo Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

``` It worked fine on Mint 21.2. Doesn't connect on either of my laptops
and worked just after I upgraded the new install last night, but then wasn't available this morning when I turned the machine on.

Why would it work until the new install was upgraded?

type or pasudo modprobe -r RTL88x2bu [AC1200 Techkey]
modprobe: FATAL: Module RTL88x2bu not found.ste code here