No WiFi after latest Stable update

Hi! This weekend I updated my system, and since then, WiFi doesn’t work.

(Edit: looks like I’m allowed proper links now; edited them back in.)

“Doesn’t work” =

  • It tries to connect for a while, then the password input pops up again
  • The same thing happens on other networks too (I tried with my phone’s hotspot)
  • To my eyes, the behavior is identical to how it reacts when I type an incorrect password (try for a bit, then ask again)
  • Other devices (two laptops and two Android phones) connect to the network as usual

Stuff I’ve tried:

  • Did sudo mv /var/lib/NetworkManager NetworkManager.backup then restarted (based on this thread, but used mv instead of rm just in case)
  • Disabled and re-enabled network manager (tried both with the WiFi toobar panel’s checkbox, and with nmcli general reload) (based on this comment)
  • Selected “All users may connect to this network” and “Store password for all users (not encrypted)” (based on this thread)
  • (EDIT) Also tried the kernels I had available to boot with (can’t install more without internet): 5.10.96-1 LTS (both normal and “fallback”) and 5.4.176-1 LTS (normal)

System details and other info:

Edit: inxi -N (manually typed from screen; typos are not impossible):

  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168

From inxi (manually typed highlights since the computer in question has no network):

  • Kernel: 5.10.96-1-MANJARO x86_64
  • KDE Plasma 5.23.5
  • CPU: AMD Ryzen 5 2600
  • Graphics: AMD Radeon RX 580
  • Network: Realtek RTL8192EE PCIe Wireless Network Adapter

lspci -vvnn | grep Network:

17:00.00 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192EE PCIe Wireless Network Adapter [10ec:818b]

systemctl status NetworkManager.service:
Shows activee (running). Log shows a bunch of (wlo1): supplicant interface state: interface_disabled -> inactive and the same for (p2p-dev-wlo1).

The update was run on 2022-02-06 at 13:30 (+0100 time).

Some things I’ve considered, but not been able to try yet:

  • (EDIT) Perhaps it’s possible to download the newest LTS kernel, 5.16, on another computer, transfer it over with a USB drive, and install it manually from the file instead of from the internet? Maybe the newer 5.16 LTS driver would help, unlike the older 5.4 I had installed and tried…
  • Connect to internet through phone by physical cable instead of hotspot (I don’t think I have cable I can use for this)
  • Connect with an Ethernet cable (I don’t think I have a cable that’s long enough. I could temporarily set up everything over there, but it would be tricky for many reasons, and certainly not possible today, so I’d like to explore all other options first if at all possible.)

And while I’ve read quite a few relevant threads, I’m sure there is more good advice to find here still. It is taking me a while to dig through the threads on my miniscule, miserably slow old travel laptop, but I will continue looking. Please feel free to ask for elaborations or things to check – I will answer as quickly as I can.

Many thanks in advance for any help and advice!

Best regards,

What is the output of inxi -N?

$ inxi -N:

  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168

(Manually typed from screen; slight chance of typos.)

It seems two network interfaces are detected, although both are down. Which one is that did work during installation but it doesn’t work now: the wired or the wireless one?

I’d expect both to work, but I was using wireless.
(The computer in question has used only WiFi for the past two years, being very impractically placed wrt Ethernet cables.)

(Please let me know if I misunderstood the question. I don’t understand the implications of the inxi output well.)

Edit: and thanks so much for helping me investigate this! The lack of internet on my only non-terrible computer is really kicking a big hole in my ability to get stuff done. Hopefully I can get the connection back up soon. :slight_smile:

I don’t see anything in the stable update that could break wifi. Perhaps you can make use of phone tethering and reinstall the wifi driver from aur.

Thanks for the reply! Yeah, I was expecting to see some wifi-related replies in the announcement thread, but found little.

About phone tethering, I can’t; it doesn’t connect to my phone’s network either.

Perhaps tethering over a physical cable could work (never tried that before), but I haven’t been able to find a cable I can use, since my new phone’s cables don’t go to ye olde USB, and my old phone refuses to start. :thinking:

In “Hardware Configuration”, I found the Network controller with network-r8168 listed ([x] open-source, [x] installed) – I guess this is the driver you are thinking of?
There’s an option to reinstall this, but I haven’t tried it yet, as I’m slightly worried it’ll first uninstall, then try to install from the network, and fail because of the missing connection. But it will reinstall fully locally/offline, right?

Edit 1:
I figured I was being silly and that surely the network driver wouldn’t rely on a working network during reinstallation, so I clicked reinstall… but it failed? :open_mouth: Details printed during the failed driver reinstallation:

> Removing network-r8168...
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/network-r8168/MHWDCONFIG
Processing classid: 0200
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 37: directive 'TotalDownload' in section 'options' not recognized.
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux54-r8168 breaks dependency 'linux54-r8168' required by linux-lts-r8168
Error: pacman failed!
Error: script failed!

Done ...

Edit 2:
Ah, looks like what I tried to reinstall was the Ethernet one anyway, as it’s listed “under” that one in the Hardware Configuration GUI.
The RTL8192EE PCIe Wireless Network Adapter entry doesn’t have any similar item listed under it. Does it mean that I simply don’t have a driver for this anymore, or does this GUI not necessarily list all drivers? :thinking:

Hi @Bralkrar ,
Please, consider to provide the output of the following terminal command in order to help us figure out what is the model of the machine you are using:
inxi --admin --verbosity=7 --filter --width

Maybe your wifi adapter is blocked, so we also need the output of another terminal command:
```rfkill list``

Do you have a keyboard input to enable or disable the wifi adapter?

Hope it helps, regards

Full output of the above commands:

$ inxi --admin --verbosity=7 --filter --width

  Kernel: 5.10.96-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=bacf80ee-7599-4389-8c72-31b039fd8f67 rw quiet
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1.00
    date: 07/02/2018
  Message: No system battery data found. Is one present?
  RAM: total: 15.64 GiB used: 3.4 GiB (21.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1619 high: 2554 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2554 2: 2496
    3: 1306 4: 1555 5: 1332 6: 1294 7: 1377 8: 1374 9: 1504 10: 1537 11: 1550
    12: 1551 bogomips: 81617
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
    cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
    fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm
    mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc
    nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse
    pse36 rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca
    sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock
    syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 1c:00.0
    chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
    s-diag: 777mm (30.6")
  Monitor-1: DisplayPort-1 res: 2560x1440 hz: 60 dpi: 118
    size: 553x311mm (21.8x12.2") diag: 634mm (25")
  OpenGL: renderer: AMD Radeon RX 580 Series (POLARIS10 DRM 3.40.0
    5.10.96-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.3.5 direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 1c:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1e:00.3 chip-ID: 1022:1457
    class-ID: 0403
  Sound Server-1: ALSA v: k5.10.96-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
    v: kernel port: e000 bus-ID: 17:00.0 chip-ID: 10ec:818b class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8168 v: 8.049.02-NAPI modules: r8169
    port: d000 bus-ID: 18:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp24s0 state: down mac: <filter>
  IF-ID-1: enp3s0f0u3 state: unknown speed: N/A duplex: N/A mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Sony Ericsson Mobile AB Xperia Mini Pro (Tethering mode) type: USB
    driver: rndis_host v: kernel bus-ID: 1-3:14 chip-ID: 0fce:7166
    class-ID: 0a00 serial: <filter>
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.35 TiB used: 550.94 GiB (40.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 71B1 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS725050A7E630
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: B390
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
    model: WD My Passport 0748 size: 465.73 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1010 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 50 GiB size: 48.22 GiB (96.43%) used: 32.92 GiB (68.3%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: bacf80ee-7599-4389-8c72-31b039fd8f67
  ID-2: /home raw-size: 379.88 GiB size: 372.91 GiB (98.17%)
    used: 288.29 GiB (77.3%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: home
    uuid: 085958fc-992b-4e42-bfe6-60f2d60cead9
  ID-3: /media/spinningdisk raw-size: 465.76 GiB size: 457.45 GiB (98.22%)
    used: 143.68 GiB (31.4%) fs: ext4 dev: /dev/sdb maj-min: 8:16
    label: SpinningDisk uuid: 1c13c7eb-bf11-4117-b2d6-149b98d9d240
  ID-4: /run/media/erling/540edb71-752e-438f-acf3-f01b09ae3af8
    raw-size: 465.73 GiB size: 457.42 GiB (98.22%) used: 86.04 GiB (18.8%)
    fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: 540edb71-752e-438f-acf3-f01b09ae3af8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.25 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 3e09be85-037c-49f2-877e-af27e7f45ac9
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:14
    info: Sony Ericsson Mobile AB Xperia Mini Pro (Tethering mode)
    type: Bluetooth,CDC-Data driver: rndis_host interfaces: 2 rev: 2.0
    speed: 480 Mb/s power: 500mA chip-ID: 0fce:7166 class-ID: 0a00
    serial: <filter>
  Device-2: 1-6:6 info: Trust Wireless Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 145f:0263 class-ID: 0301
  Device-3: 1-8:3 info: SiGma Micro USB Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 98mA chip-ID: 1c4f:0027 class-ID: 0300
  Device-4: 1-9:4 info: Western Digital My Passport (WDBKXH WDBY8L)
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.1
    speed: 480 Mb/s power: 500mA chip-ID: 1058:0748 class-ID: 0806
    serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 51.6 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1042
  Processes: 347 Uptime: 33m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1550 lib: 446
  flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.12


$ rfkill list

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Note that I’m now able to install/update stuff, as I managed to start my oldest smart phone and use its WiFi over USB. Definitely not a long-term solution, but having the connection to update stuff is certainly helpful.
I’m installing the newer 5.15 LTS kernel as we speak, and hoping that’ll help.

Edit: the newer kernel made it work, as hoped! :smiley:


Short version: Installed and used kernel 5.15 (LTS), up from 5.10.

More details:

  • Installed kernel 5.15 (LTS) from the usual Kernel control panel GUI in Manjaro, then restarted, and selected the new kernel when booting
  • I couldn’t do this yesterday because I had no internet to do it from. But today I dug up my oldest smart phone, for which I did have a USB cable I could tether over to use its WiFi.
  • Upgrading/downgrading the kernel has been the solution every time I’ve had issues with Manjaro in the past, so I had high hopes this time. I’m glad it didn’t disappoint once installing it became possible! :smiley:

Anyway, to everyone who has helped me look into this in the meantime, thank you so much! May your cookies always be edible, and may your coffee always be just right.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.