No Wifi Adapter found wireless wifi not working

I am new to the Manjaro OS. And right after installation, wireless wifi is not working. It works with wired connection. I’ve gone through 2… or 3 solution but its not working. Please help me.
i am using Acer aspire laptop
OS: Manjaro Linux x86_64
Host: Aspire 4752 V2.15
Kernel: 6.6.8-2-MANJARO
GNOME 45.2

Is wi-fi perhaps disabled? I’m running xfce ; right click the NM icon to see.


i cant turn it on

Maybe try this cmd in a terminal.
nmcli radio wifi on

Sorry I miss “No Wi-Fi adapter found” in your last post

what does the output of the cmd
inxi -n

did it. But it’s not working
image

Do you happen to have a switch on you laptop? Internet search gave this:

issue was due to a button on the lower part of my laptop

Yeah I can see wifi like button in F3 but it only toggles the airplane mode not the wifi.

Airplane mode must be off. And here’s another search:
You usually have a button or switch on your wifi adapter which can be used to forcibly stop the signal. There is nothing you can do in software to change that, only observe it (but note that there are some drivers which do not observe it correctly, and always generate one result); you need to press the button or flip the switch.

also is it F3 or Fn+f3

If it were doable in software it would be

sudo ip link set dev wlp2s0 up

It is a bit confusing because you have the inxi output which shows the wireless state as down and the device as wlp2s0…but in rfkill the acer-wireless is neither soft nor hard blocked. But phy0 device is hard blocked.

‘Hard blocked’ indeed refers to a physical button or switch on the device.

Yes, “It is a bit confusing”, and I’m kinda at a loss at this point.
Are you using the laptop now, to post here? Without a Wired connection, or what?
Possibly a systemctl restart NetworkManager command?

(I asked because the last inxi output showed that your Ethernet device was down too.
Any way, I bailing out. Hopefully someone with a lot more knowledge will jump in and help you. I’ll be watching to see the answer.
Sorry I couldn’t help

<Solved> Wifi Not Working: Mint 19.3 [Acer Aspire 4752] - Linux Mint Forums

Previously on Mint 17 to 18.3 I had to turn on Wifi switch with Fn+F3 keys to remove the hard block every time i boot, but it doesn’t seem to work now.

Machine:   Type: Laptop System: Acer product: Aspire 4752 v: V2.15 serial: <filter> 
           Mobo: Acer model: Aspire 4752 v: V2.15 serial: <filter> UEFI: Phoenix v: 2.15 date: 12/05/2011 
echo "blacklist acer-wmi" |sudo tee /etc/modprobe.d/acer-wmi.conf

Then reboot

https://askubuntu.com/questions/1073710/wifi-is-disabled-on-acer-aspire-4752

I’ve solved the issue by blacklisting acer_wmi and rfkill unblock all after.