"No such cryptodisk found" after Virtual Box update

I’m using Manjaro XFCE stable branch in Virtual Box with full disc encryption (set up via Manjaro installer). It worked fine for almost a year, but when I updated Virtual Box (on host system from 6.0 to 6.1) my Manjaro guest failed to find the cryptodisk after rebooting:

I wanted to post a screenshot or a link to a screenshot, but unfortunately I’m not allowed. You can find the screenshot here (please remove the space before org: upload.disroot. org/r/201qawp9#hYQNW6ehtqjBPxOiu56lj89Qg+Xxcgp8m7IdaBA1frY=

The only other thing I did on my guest system since last reboot is the update of Manjaro Update Script.

As I have absolutly 0 experience with grub I need help in form of an ELI5. Is that possible? All the threads I found on this topic required too much grub experience.

Thanks in advance.

@bronix Instructions for switching branch are available in the WIKI.

1 Like

Tested in Virtualbox. You must mistyped your password:

Or maybe if have used a different keymap, it could be reset to US keymap.

1 Like

Maybe I should have mentioned that I already retyped my password multiple times and in QWERTY and QWERTZ layout. I’m 100% sure to have the correct password.

So… there must be another problem I still News to find.

Problem solved.

Indeed it was the wrong password because Virtual Box had a problem that it didn’t use QWERTZ / QWERTY anymore. After a restart of both, Virtual Box and the host system, login in grub went smoothly again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.