No sound on Laptop with Intel Tiger Lake HD Audio / Audio hardware not detected

Hi all,

I´m a long time user and supporter of manjaro without too much skills.
I´ve read different sound problem topics in this forum and googled a lot but the solutions did not help me.

My problem:
My audio hardware is not detected in pulse and pipewire. I cannot choose it to play sound.
Sound is completely deactived and I cannot activate any devices.

My Hardware:
MSI Katana GF66 UG-220 Laptop.
Intel Tiger Lake HD-Audio
Laptop has two speakers build in.

inxi -Ax Output is

Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 
           Device-2: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           Sound Server-1: ALSA v: k5.14.7-2-MANJARO running: yes 
           Sound Server-2: sndio v: N/A running: no 
           Sound Server-3: JACK v: 1.9.19 running: no 
           Sound Server-4: PulseAudio v: 15.0 running: yes 
           Sound Server-5: PipeWire v: 0.3.37 running: yes 

mhwd -lh -d --pci Output for the relevant part

18: PCI 1f.3: 0401 Multimedia audio controller
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Device Name: "Onboard - Sound"
  Model: "Intel Tiger Lake-H HD Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x43c8 "Tiger Lake-H HD Audio Controller"
  SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
  SubDevice: pci 0x12fc 
  Revision: 0x11
  Driver: "sof-audio-pci-intel-tgl"
  Driver Modules: "snd_sof_pci_intel_tgl"
  Memory Range: 0x6203148000-0x620314bfff (rw,non-prefetchable)
  Memory Range: 0x6203000000-0x62030fffff (rw,non-prefetchable)
  IRQ: 158 (1356 events)
  Module Alias: "pci:v00008086d000043C8sv00001462sd000012FCbc04sc01i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Driver Info #1:
    Driver Status: snd_sof_pci_intel_tgl is active
    Driver Activation Cmd: "modprobe snd_sof_pci_intel_tgl"

MHWD detects the sound card and driver is installed.
There seems to be an issue with pulse or pipewire to let it be chosen as as a soundcard or to detect the output speakers.

Any help and suggestions welcomed.

Many thanks & kind regards

To add after more trouble shooting and searching:
It seems, that somehow the speakers are not detected as an output possibility.

Any suggestions?

This did not help too.

Just to add:
The sound works under Linux Mint 20.2 right fine out of the box.
Windows also has directly no issues.
So it´s not a hardware problem here.
It´s a software issue under Manjaro KDE 21.1.4.

Are you running both pipewire and pulseaudio - my understanding is that it is one or the other.

Are you using pipewire or pulseaudio on Mint?

EDIT: better link Sound is muffled compared to Windows 10 - #9 by nikgnomic

1 Like

Which option did you choose from the two suggestions:

  1. Disable the Pipewire systemd services to use PulseAudio

  2. Install the Pipewire meta package to replace PulseAudio

Please post more information about the active sound server

pactl list cards && pactl list sinks

Interesting, in Manjaro are after the installation directly both activated.
Maybe due to HDMI Sound via GPU and onboard sound via Intel cip seperately.

As stated above, both were automatically installed and activated.

pactl list cards && pactl list sinks Results

Karte #0
        Name: alsa_card.pci-0000_01_00.1
        Treiber: module-alsa-card.c
        Owner-Modul: 6
                alsa.card = "0"
                alsa.card_name = "HDA NVidia"
                alsa.long_card_name = "HDA NVidia at 0x82080000 irq 17"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:01:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card0"
                device.bus = "pci"
       = "10de"
       = "NVIDIA Corporation"
       = "228b"
       = "GA104 High Definition Audio Controller"
                device.string = "0"
                device.description = "GA104 High Definition Audio Controller"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                output:hdmi-stereo: Digital Stereo (HDMI)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 5900, verfügbar: nein)
                output:hdmi-surround: Digital Surround 5.1 (HDMI)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 800, verfügbar: nein)
                output:hdmi-surround71: Digital Surround 7.1 (HDMI)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 800, verfügbar: nein)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 5700, verfügbar: nein)
                output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 5700, verfügbar: nein)
                output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 5700, verfügbar: nein)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4)-Ausgabe (Ziele: 1, Quellen: 0, Priorität: 600, verfügbar: nein)
                off: Aus (Ziele: 0, Quellen: 0, Priorität: 0, verfügbar: ja)
        Aktives Profil: off
                hdmi-output-0: HDMI / DisplayPort (type: HDMI, priority: 5900, latency offset: 0 usec, not available)
                                device.icon_name = "video-display"
                        Teil der/des Profil(s): output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71
                hdmi-output-1: HDMI / DisplayPort 2 (type: HDMI, priority: 5800, latency offset: 0 usec, not available)
                                device.icon_name = "video-display"
                        Teil der/des Profil(s): output:hdmi-stereo-extra1, output:hdmi-surround-extra1, output:hdmi-surround71-extra1
                hdmi-output-2: HDMI / DisplayPort 3 (type: HDMI, priority: 5700, latency offset: 0 usec, not available)
                                device.icon_name = "video-display"
                        Teil der/des Profil(s): output:hdmi-stereo-extra2, output:hdmi-surround-extra2, output:hdmi-surround71-extra2
                hdmi-output-3: HDMI / DisplayPort 4 (type: HDMI, priority: 5600, latency offset: 0 usec, not available)
                                device.icon_name = "video-display"
                        Teil der/des Profil(s): output:hdmi-stereo-extra3, output:hdmi-surround-extra3, output:hdmi-surround71-extra3
Ziel #0
        Status: SUSPENDED
        Name: auto_null
        Beschreibung: Dummy-Ausgabe
        Treiber: module-null-sink.c
        Abtastwert-Angabe: s16le 2ch 44100Hz
        Kanalzuordnung: front-left,front-right
        Besitzer-Modul: 17
        Stumm: nein
        Lautstärke: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
                Verteilung 0,00
        Basis-Lautstärke: 65536 / 100% / 0,00 dB
        Quellen-Monitor: auto_null.monitor
        Latenz: 0 usec, eingestellt 0 usec
                device.description = "Dummy-Ausgabe"
                device.class = "abstract"
                device.icon_name = "audio-card"

1 Like

Linux Mint as Ubuntu are using Pulseaudio according to my information.
So I will test removing pipewire.

Sadly, removing Pipewire broke something in my KDE session. Was not able to open it again.

Reinstalled and tried to uninstall pulseaudio. Sadly another KDE session break.

There seem to be dependencies.

Reinstalled again fresh from ISO.

Using the instructions to deinstall pulse of

does break plasma-pa, as it obviously has a pulseaudio dependency.

Now I´m searching to deactivate pipewire.service at least.

Maybe this could help:

But I simpy cannot follow it to execute.
I donnot know how.

There is no


on my system, even though it states in inxi -Ax that Pipewire is running.

oh dear!

this discussion may be relevant:

Thank you.
Will try and check tomorrow evening.
Not enough energy for this to check and fix now once again. :wink:

I do not recognise author of the blog post from May 11, 2021

See this post for latest information on managing incompatible sound servers

Just to document for future people, how I tried to tackle this.

systemctl --user list-unit-files | grep pipewire                                                                                                                                                                 ✔  36m 24s  
pipewire-media-session.service                             enabled   enabled
pipewire.service                                           disabled  enabled
pipewire.socket                                            enabled   enabled
    ~  systemctl enable pipewire.service                                                                                                                                                                                            ✔ 
Failed to enable unit: Unit file pipewire.service does not exist.
    ~  systemctl --user list-unit-files | grep pulse                                                                                                                                                                       1 ✘  7s  
pulseaudio-x11.service                                     static    -
pulseaudio.service                                         disabled  enabled
pulseaudio.socket                                          enabled   enabled
    ~  systemctl enable pulseaudio.service                                                                                                                                                                                          ✔ 
Failed to enable unit: Unit file pulseaudio.service does not exist.

I am not able to activate pulseaudio.service nor pipewire.service
So I am not able to find any audio hardware in my configuration settings.

I installed manjaro-pipewire as suggested.
It brought me one step forward.

After rebooting, I´m able to see audio devices.

But as you can see, I cannot choose any profile for the stereo output speakers.
Still no sound possible.

Found the solution here:

Quoting Goose:

I found a workaround on the Ubuntu forum. Scroll down to the bottom and someone responded with a solution for Arch. Basically, follow these steps:

Edit grub config
sudo nano /etc/default/grub

Add the following within the quotation after GRUB_CMDLINE_LINUX_DEFAULT

Update grub
sudo update-grub


This forces the legacy driver, or in my case, forces the laptop internal audio to be default, rather than the HDMI.

Here’s the link to the thread where I found that solution:

1 Like

There is another way to add this modprobe option that does not require editing GRUB

Can not record my voice in manjaro i3

echo 'options snd-intel-dspcfg dsp_driver=1' | sudo tee -a /etc/modprobe.d/alsa-legacy.conf > /dev/null`
1 Like

Just to inform about the second solution:

Undid my grub change, updated grub without the change and restarted.
Tried this input and it did not work for me.

So I changed back to my first solution with the grub change.