No sound on laptop speaker's left channel

Hello, I’m facing a persistent audio issue on my newly installed Manjaro XFCE, on my HP ENVY Touchsmart k012x: my laptop speaker’s left channel doesn’t produce any output.

I tested my audio on: Left / Right Stereo Sound Test (Online). The right channel works, the ‘center’ channel works only via the right channel, and the left channel produces no sound at all.

What I have tried:

  • I have enabled stereo via PulseAudio (by tapping on the lock sign on the window). After doing so, both left and right channels are shown at 100, but there’s no audio.
  • Playing sound on headphones. Audio plays perfectly on headphones, but doesn’t on the speakers.

Further details of my system after running the neofetch command on terminal:

OS: Manjaro Linux x86_64
Host: HP ENVY TS 14 Sleekbook 0888100000305B0000
Kernel: 5.11.2-1-MANJARO
Uptime: 12 mins
Packages: 1299 (pacman)
Shell: bash 5.1.0
Resolution: 1366x768
DE: Xfce 4.16
WM: Xfwm4
WM Theme: Dracula-alt-style
Theme: Dracula-standard-buttons [GTK2/3]
Icons: Sweet-Rainbow [GTK2/3]
Terminal: xfce4-terminal
Terminal Font: DejaVu Sans Mono 11
CPU: Intel i5-4200U (4) @ 2.600GHz
GPU: Intel Haswell-ULT
Memory: 1740MiB / 3864MiB

I understand not all of this info might be relevant to this problem, but I’m happy to pull any additional info as needed. Thanks!

Did you try with another OS before to install Manjaro ? Like any other distro or non-Linux OS ?
You could also try to uninstall pulseaudio and install asla instead, there is alsa mixer with which you have the possibility to set the balance audio in command line to make some additional tests.

1 Like

Yep, I had Windows 10 on this machine before, and the speakers did work.

It looks like I currently have both PulseAudio and alsa on this machine – I’m happy to uninstall PulseAudio to run some tests. But just to check, the audio should still work without PulseAudio, right? Or if it doesn’t, I should be able to reinstall, correct?

If so, would love to know what tests I could run from the command line to identify/resolve the issue via alsa. Thanks a lot!

From memory it’s something like

amixer sset Master 70%,30%

You can also run “alsamixer” in a console for more visually controls.
But in any case, you may read man pages for both amixer or alsamixer and play with them.
And then use any audio player to see what you get (“aplay” if you want it in command line)

1 Like

You need hdajackretask which is in the alsa-tools package, so:

pamac install alsa-tools

In that screen you need to:

  • Select the correct codec
  • Click Show unconnected pins

and then it becomes fuzzy as I have no system information on your sound hardware but basically you need to override one or more of the unconnected pins to the features you want.

  • Once you’ve done all of the needed overrides, you need to click Apply now and test.
  • If that would give you an error message, you need to:
    • Click Boot override
    • Reboot
    • Test

Repeat until you get what you want.


1 Like

Wow, thanks for this - I seem to be getting somewhere! The good news is, this solved a different notorious issue with my machine: it comes with Beats Audio subfwoofers, but I could never get them to work. Playing around with the unconnected pin configs seems to have at least enabled Beats Audio – it’s always on, so I can’t toggle it on/off, but I’ll take it.

Now to the main issue: I’ve tried a few combinations, and what they all do achieve is to channel both left and right channels through the right speaker. Here’s how the setup looks:

Key details:

  • Codec: IDT 92HD91BXX
  • ‘Pre-connected’ pin (this pin was already checked the first time I used hdajackretask: 0x0d (Internal Speaker, Front side)
  • Unconnected pins (which I’ve now connected as per the above screenshot): 0x0e, 0x0f, 0x10
  • Device model, as above: HP ENVY TS 14 Sleekbook 0888100000305B0000

As you can tell, I’m currently on the following setup:

0x0d: Internal speaker
0x0e: Internal speaker (Back)
0x0f: Internal speaker (LFE)
0x10: Internal speaker

I’m assuming each ‘channel’ (Internal speaker, Internal speaker (Back), Internal speaker (LFE)) can only be assigned to one of the unconnected pins (excluding the pre-connected 0x0d)? If so, then I’ve tried all 6 possible combinations of assigning these uniquely to each of 0x0e, 0x0f and 0x10.

It does seem that a similar issue came up for an Arch user back in 2014, on a 15" version of my 14" machine. In their case, the issue was that the ‘left’ speaker is actually on the center-right of their model, so the sound just seemed to come from the right.

In my case, sound only comes from the right channel. I couldn’t find an exact schematic for my machine, but assuming it’s the same as for the above user, the sound still isn’t coming from where it should be, in case my speaker is also center-right.

Could there be a different way to fix this? Thanks a lot for the help so far!

I guess to be more specific, by ‘different way’ I meant:

  • PulseAudio is also running on this machine. Should I uninstall this and try again?
  • Is there a diagnostic I can run on this machine (or through a USB) to test if this is a hardware or software problem? I tried the in-built HP Diagnostics tool at boot (by pressing Esc and then F2 right after power on), but it only had a memory test option, no audio test option.

Any other pointers most appreciated of course, haha. Thanks!

What are the contents of the drop-down box, please? (as i don’t have the exact same hardware as you I can’t give you a silver bullet)


Maybe an idea to try a live USB with an different distro, to make sure that it’s not hardware related?

1 Like

You said out loud what I was thinking…


Codec: IDT 92HD91BXX
has an old bug report about the 4.1 internal speaker system

I suspect that modprobe option hp-envy-ts-bass would get the speakers working

But Archwiki suggests retasking 2 jacks for other HP laptop models with similar Sigmatel audio codec + 5 speakers

HP Envy TouchSmart 15j - ArchWiki
0x0d - Internal speaker
0x0f - Internal speaker
0x10 - Internal speaker (LFE)

HP Envy 15 - ArchWiki
Audio – j013sg and j082sf

hdajackretask in the package extra/alsa-tools can be used to remap the unconnected 0x0f pin to Internal Speaker, and the 0x10 pin to the subwoofer (Internal Speaker LFE).

1 Like

Thank you so much everyone. Unfortunately, I’ve had to be away from laptop for some time, but I should be able to test out audio from a flash drive and @nikgnomic’s tip by Thursday. Really appreciate your help, and will report back right away once I’m back online!