No sound in manjaro x64 xfce

I have an Asus V221ID and the audio doesn’t work on ALL linux distributions. Idk what to do
Here the specs:

  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=ab4b6ea3-339e-4e12-aaa6-61a6db8857a6 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: ASUSTeK product: V221ID v: 0501 serial: <filter> 
  Chassis: type: 13 v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: V221ID v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 0501 date: 01/12/2017 
  Info: Dual Core model: Intel Celeron J3355 bits: 64 type: MCP arch: Goldmont 
  family: 6 model-id: 5C (92) stepping: 9 microcode: 40 cache: L2: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 7990 
  Speed: 799 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 799 2: 799 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 500 vendor: ASUSTeK driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:5a85 class-ID: 0300 
  Device-2: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus-ID: 1-6:7 chip-ID: 0bda:57f6 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 
  OpenGL: renderer: Mesa Intel HD Graphics 500 (APL 2) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:0e.0 chip-ID: 8086:5a98 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: AzureWave driver: ath9k v: kernel port: e000 bus-ID: 03:00.0 
  chip-ID: 168c:0036 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-5:9 
  chip-ID: 13d3:3472 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 946.06 GiB used: 6.84 GiB (0.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 5J scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston 
  model: DataTraveler 2.0 size: 14.54 GiB block-size: physical: 512 B 
  logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw-size: 234.53 GiB size: 229.79 GiB (97.98%) used: 6.82 GiB (3.0%) 
  fs: ext4 dev: /dev/sda5 maj-min: 8:5 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 174 Uptime: 45m wakeups: 0 Memory: 3.67 GiB 
  used: 1.64 GiB (44.7%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1059 lib: 298 flatpak: 0 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.04 

Welcome to the forum!/Bienvenido al foro! :wave:

Not my field of expertise, but it looks like the Intel driver is loaded for your device. Pulseaudio seems to be enabled as well.

I’d recommend you take a look at the guidance for PulseAudio in Arch Wiki

Hope that helps!

have you selected the correct output on the volume icon?
it’s common to be set headphones on most distros, as that is usually considered the primary.

1 Like

After searching the device: I came to conclusion that the wrong driver has been loaded.

It must be this one: snd_sof_pci instead of snd_hda_intel. Try to blacklist it:

echo "blacklist snd_hda_intel" > /etc/modprobe.d/blacklist_snd_hda_intel.conf

Maybe you have to install sof-firmware also:

pamac install sof-firmware

The reboot and check again which driver has been loaded:

sudo inxi -Aazy
1 Like

Sorry, my post deleted

I don’t give the fish to anyone, I offer the rod for him to go fishing

T+ = See you later

1 Like

Could you explain me how to fix it?

@GitMg I explained everything in short. Could you explain what is not clear enough?

I mean, I did not understand what commands to use and what to do

  1. driver snd_hda_intel is loaded and alternates are snd_soc_skl and snd_sof_pci.
  2. You need to create text file at /etc/modprobe.d/ with a custom name like blacklist_snd_hda_intel.conf with the content blacklist snd_hda_intel.
    That is done with this command:
sudo echo "blacklist snd_hda_intel" > /etc/modprobe.d/blacklist_snd_hda_intel.conf
  1. Now it should skip this driver and use instead the next possible driver at the next boot time which could work better.
  2. Also keep sure the firmware for sof (Sound Open Firmware) is installed:
pamac install sof-firmware
  1. Check again with this command, which driver has been loaded for your audio device:
inxi -Aazy

Is it clearer?

I still have no sound

  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
  vendor: ASUSTeK driver: snd_soc_skl v: kernel
  alternate: snd_hda_intel,snd_sof_pci bus-ID: 00:0e.0 chip-ID: 8086:5a98
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.63-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.35 running: yes

Linux hardware scan in post#4 is showing a new Sound Open Firmware driver SND_SOC_SOF_INTEL_APL (for Apollo Lake systems) supported by kernel v5.12 and later

I suggest you install kernel v5.15 using Manjaro Settings Manager GUI
( manjaro-settings-manager -m msm_kernel )

OR use this terminal command

sudo mhwd-kernel --install linux515
1 Like