No sound in internal speakers. Micro doesn't work. Bluetooth headset sounds but micro doesn't work


In a new Manjaro installation on a HP laptop, internal speakers and micro don’t work and when I connect a bluetooth headset, I can listen sounds but micro doesn’t work.

Here there are some data:

  • inxi -Fazy shows following:
      Kernel: 5.15.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
      parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
      root=UUID=ab49af1a-ae80-48d2-926c-5f95ade3e4ea rw quiet apparmor=1
      security=apparmor udev.log_priority=3
      Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 2 dm: SDDM
      Distro: Manjaro Linux base: Arch Linux
      Type: Laptop System: HP product: HP Laptop 15s-fq2xxx v: N/A
      serial: <superuser required> Chassis: type: 10 serial: <superuser required>
      Mobo: HP model: 87FE v: 57.18 serial: <superuser required> UEFI: AMI v: F.14
      date: 09/08/2021
      ID-1: BAT0 charge: 42.4 Wh (100.0%) condition: 42.4/41.0 Wh (103.3%)
      volts: 12.8 min: 11.4 model: HP Primary type: Li-ion serial: <filter>
      status: Full cycles: 1
      Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
      charge: 55% (should be ignored) rechargeable: yes status: Discharging
      Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
      arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 8A
      cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
      flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
      bogomips: 38720
      Speed: 714 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 612 2: 1181
      3: 1044 4: 1282 5: 1224 6: 1265 7: 1237 8: 1536
      Vulnerabilities: Type: itlb_multihit status: Not affected
      Type: l1tf status: Not affected
      Type: mds status: Not affected
      Type: meltdown status: Not affected
      Type: spec_store_bypass
      mitigation: Speculative Store Bypass disabled via prctl and seccomp
      Type: spectre_v1
      mitigation: usercopy/swapgs barriers and __user pointer sanitization
      Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
      Type: srbds status: Not affected
      Type: tsx_async_abort status: Not affected
      Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
      driver: i915 v: kernel bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
      class-ID: 0300
      Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
      bus-ID: 1-3:3 chip-ID: 0408:5365 class-ID: 0e02
      Display: x11 server: X.Org compositor: kwin_x11 driver:
      loaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1
      Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2")
      s-diag: 1055mm (41.5")
      Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6")
      diag: 394mm (15.5")
      Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7")
      diag: 604mm (23.8")
      Message: Unable to show advanced data. Required tool glxinfo missing.
      Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
      driver: sof-audio-pci-intel-tgl
      alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
      chip-ID: 8086:a0c8 class-ID: 0401
      Sound Server-1: ALSA v: k5.15.6-2-MANJARO running: yes
      Sound Server-2: JACK v: 1.9.19 running: no
      Sound Server-3: PulseAudio v: 15.0 running: yes
      Sound Server-4: PipeWire v: 0.3.40 running: yes
      Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
      vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
      port: 3000 bus-ID: 0000:01:00.0 chip-ID: 10ec:c822 class-ID: 0280
      IF: wlo1 state: up mac: <filter>
      Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
      bus-ID: 1-10:4 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
      Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
      Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
      v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
      Local Storage: total: 476.94 GiB used: 21.48 GiB (4.5%)
      SMART Message: Unable to run smartctl. Root privileges required.
      ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H
      size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
      lanes: 4 type: SSD serial: <filter> rev: HPS1 temp: 50.9 C scheme: GPT
      ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
      used: 21.48 GiB (4.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
      ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
      used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
      Alert: No swap data was found.
      System Temperatures: cpu: 56.0 C mobo: N/A
      Fan Speeds (RPM): N/A
      Processes: 259 Uptime: 1h 1m wakeups: 4 Memory: 31.01 GiB
      used: 3.9 GiB (12.6%) Init: systemd v: 249 tool: systemctl Compilers:
      gcc: N/A Packages: 1249 pacman: 1238 lib: 339 flatpak: 0 snap: 11 Shell: Zsh
      v: 5.8 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09
  • pacmd list-cards shows 0 card(s) available.
  • aplay -l shows aplay: device_list:274: no soundcards found...
  • sudo dmesg | grep snd shows following:
    [    1.875225] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [    1.875248] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
  • lscpi -v shows following:
    0000:00:1f.3 Multimedia audio controller: Intel Corporation Tiger Lake-LP Smart Sound Technology Audio Controller (rev 20)
          Subsystem: Hewlett-Packard Company Device 87fe
          Flags: bus master, fast devsel, latency 32, IRQ 16
          Memory at 6003230000 (64-bit, non-prefetchable) [size=16K]
          Memory at 6003000000 (64-bit, non-prefetchable) [size=1M]
          Capabilities: <access denied>
          Kernel driver in use: sof-audio-pci-intel-tgl
          Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl
  • amixer shows:
    Simple mixer control 'Master',0
      Capabilities: pvolume pswitch pswitch-joined
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 65536
      Front Left: Playback 65536 [100%] [on]
      Front Right: Playback 65536 [100%] [on]
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch cswitch-joined
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 65536
      Front Left: Capture 65536 [100%] [on]
      Front Right: Capture 65536 [100%] [on]
  • pacmd list-sources shows:
    1 source(s) available.
      * index: 0
            name: <combined.monitor>
            driver: <module-combine-sink.c>
            state: SUSPENDED
            suspend cause: IDLE
            priority: 1000
            volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                    balance 0.00
            base volume: 65536 / 100% / 0.00 dB
            volume steps: 65537
            muted: no
            current latency: 0.00 ms
            max rewind: 0 KiB
            sample spec: s16le 2ch 44100Hz
            channel map: front-left,front-right
            used by: 0
            linked by: 0
            configured latency: 0.00 ms; range is 0.50 .. 200.00 ms
            monitor_of: 0
            module: 14
                    device.description = "Monitor of Simultaneous Output"
                    device.class = "monitor"
                    device.icon_name = "audio-input-microphone"

I have read a lot of posts and I have tried some things but nothing works.

Thanks in advance for your help

Seems internal sound hardware isn’t detected by alsa, is sof-firmware installed?

You are on Kernel 5.15, have you tried switching to LTS 5.10 kernel?

1 Like

@darkcity Thanks for your comment about the kernel. I just started using Manjaro and didn’t notice my audio wasn’t working. Switching to LTS 5.10 fixed it.

@antoniocrevel I’ve been messing around with my audio issue too. I’m no expert at all. Changing the kernel to 5.10 fixed the issue for me.

…but… I noticed in your inxi output, you had PulseAudio and PipeWire running at the same time.

I saw that they can’t be used together. There was another post here:
Can’t post full URL, the end of it is: /t/sound-stopped-working/63669

My fresh install and updates left me with kernel 5.15 and PulseAudio running with no audio. Tried a couple of things and both worked.

  1. Remove PulseAudio and switch to PipeWire (keep the 5.15 kernel)
  2. Leave PulseAudio and just go back to kernel 5.10

I briefly looked at what PipeWire is and it sounded better than PulseAudio – I spent about 2 minutes looking so I don’t know for sure! I’m going to keep the newer kernel and use PipeWire.

1 Like

Thanks @darkcity and @tfios for your answers.

I have tried first @tfios solution.
sof-firmware wasn’t installed. After it was installed, most of devices run. Laptop speakers and micro run correctly. Jack headset also runs but wireless bluetooth don’t.

I will try other solutions suggested

Thanks a lot

1 Like