No sound i got and boot problems- Manjaro linux

So today i installed manjaro linux, trying it, i got problems, i cant even boot it properly ( i figured i can every time type sudo lightdm and it boots somehow) and i have no sound. I need help - i copy-pasted the kernel info or smth

  Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=943451a6-76ef-49fe-836a-4dff75c15458 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: Gigabyte model: H81M-S1 v: x.x serial: <filter> 
  BIOS: American Megatrends v: FF date: 06/20/2014 
  Message: No system battery data found. Is one present? 
  RAM: total: 3.73 GiB used: 1.72 GiB (46.2%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i3-4170 bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: 
  L2: 3 MiB bogomips: 29532 
  Speed: 1097 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 1097 2: 1098 
  3: 1098 4: 1098 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 
  bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 
  dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu 
  fsgsbase fxsr ht ibpb ibrs invpcid invpcid_single lahf_lm lm mca mce 
  md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid 
  pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand 
  rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp 
  syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi 
  vpid xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 4th Generation Core Processor Family Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:041e 
  class-ID: 0300 
  Device-2: NVIDIA GK208B [GeForce GT 710] vendor: Gigabyte driver: nouveau 
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") 
  s-diag: 485mm (19.1") 
  Monitor-1: VGA-2 res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.4x9.8") 
  diag: 508mm (20") 
  OpenGL: renderer: llvmpipe (LLVM 11.1.0 256 bits) v: 4.5 Mesa 21.0.3 
  compat-v: 3.1 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c 
  class-ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:8c20 class-ID: 0403 
  Device-3: NVIDIA GK208 HDMI/DP Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0f 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.34-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: no 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 223.57 GiB used: 6.36 GiB (2.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: B1D1 scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 223.57 GiB size: 219 GiB (97.96%) used: 6.36 GiB (2.9%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 943451a6-76ef-49fe-836a-4dff75c15458 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:2 info: China Resource Semico USB Keyboard 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 1.5 Mb/s power: 100mA chip-ID: 1a2c:0c21 class-ID: 0301 
  Device-2: 3-3:3 info: SteelSeries ApS SteelSeries Rival 3 type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s 
  power: 400mA chip-ID: 1038:184c class-ID: 0300 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 
  speed: 5 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 44.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 2430 
  Processes: 181 Uptime: 12m wakeups: 0 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: N/A Packages: pacman: 1058 lib: 298 flatpak: 0 Shell: Bash 
  v: 5.1.4 running-in: xfce4-terminal inxi: 3.3.04

Welcome to the forum! :slight_smile:

I cannot help you with regard to lightdm not starting ─ I’m sure somebody else will jump in on the thread, though ─ but with regard to your sound problem, there’s this from your output above… :arrow_down:

I would advise you to run the following command in a terminal window (or logged in at a tty)… :arrow_down:

sudo systemctl enable --now pulseaudio

You only need to do this once, because it appears that your system is booting without PulseAudio enabled, and the command I just gave you enables it and makes it active right away, all in the same go.

1 Like

Hey! Thanks but other question - i typed it and got :
\Failed to enable unit: Unit file pulseaudio.service does not exist
how do i install it?

Hmm… It should be installed by default. :thinking:

Okay, try this ─ as yourself, not as root… :arrow_down:

systemctl enable --user --now pulseaudio.service
systemctl enable --user --now pulseaudio.socket

It seems i am missing something - :< same with 2 commands
Failed to enable unit: Process org.freedesktop.systemd1 exited with status 1

Hmm… Either you’ve downloaded a corrupted install image, or there is something wrong with your hardware. I did notice that your machine only has 4 GiB of RAM, which tells me that it’s not exactly the most recent machine, and therefore, the hardware might be showing signs of old age.

A common point of failure in older machines would be the power supply, not supplying the correct voltages anymore to all connectors. :thinking:

Oh no :x i downloaded it from official website the XFCE version.
And yes it is a quite old machine ;/
is there anything more to do or should i try to format and reinstall the system once again?
and i think i got power supply working, didnt see any problems recently. just changing os cause previous didnt want to cooperate with me.

Did you check the SH1 checksum against the one on the download page after downloading?

What was the previous one?

Em no i didnt checksum against the one on the download page, the previous was win10
so should i check it?

I’m sure there are utilities for checking SHA checksums in Windows, but I can’t give you any advice on that, because I don’t do Windows.

In order to check the sha1 checksum in Manjaro, you run… :arrow_down:

sha1sum name-of-the-file

… and you compare that to the checksum listed on the website.

Yet, if Windows also had difficulties on that machine, then everything does point at faulty hardware. It could be as simple as a faulty RAM module, but it could also be something more substantial, such as the power supply, or the CPU running too hot. :man_shrugging:

1 Like

Hey! Sorry for late response. I double checked he iso file, it was all fantastic and good. So i will try to look if i have any faulty components as u said ! thanks for the help. if i will find something maybe i will come back XD

well i checked my pc, hmm. it is not great but i cleaned it and first time i didnt get full black on boot - i got FAILED TO START Light Display Manager, and i also tried commands from audio /\ the answers before
EDIT ***

Unknown command verb pulseaudio.socket

[fifi@Mantus ~]$ systemctl enable --user --now pulseaudio.socket
Failed to enable unit: Process org.freedesktop.systemd1 exited with status 1

i typed it only this worked and gave me other call
what`s wrong?! my machine is dumb or am i? xD

HELLO ! i came to say i got it working! Thanks for the help after hours of searchign and asking advices i find the simple solution.
for anybody who finds it - boot problem was caused by the noveua drivers - i needed to change it to nonfree nvidia. it fixed the solution. and for the audio i just tried bunch of ways most likely reinstalling pulseaudio worked :“systemctl --user --full --no-pager status pulseaudio.{socket,service}
If it returned inactive, type: systemctl --user restart pulseaudio
If the installation is corrupted, then reinstall pulseaudio, it might be your solution:
sudo pacman -Rsu pulseaudio ; reboot”
so ONCE AGAIN thanks! <3