No sound from speakers\headphones Acer switch 10

Hello, I installed this amazing OS on the above old PC and everything runs great except sound.

It’s on kernel 6.1 and it’s a bytcr-rt5640 realtek.
Tried everything, no luck

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: bytcrrt5640 [bytcr-rt5640], device 0: 1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: bytcrrt5640 [bytcr-rt5640], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any idea?

What else should we suggest if you already tried everything?

Well, it meant everything I know which is quite limited
Everything I saw in relation to that chip, again very limited

Hi there! One thing - have you tried installing a couple of alternative LTS kernels & booting into each of them, to see if you get results? If not, I would go install 5.10 & 5.15 and see if your machine prefers one of those. I would also make sure you’ve played around enough with your audio settings. Also, did you go for proprietary or open source drivers? I always select open source & have never had issues. Try those & see if you get any mileage. More power to you. R

Thanks for the suggestion. I tried Manjaro and few arch distros with different DE (all light). They all boot and everything works except audio. All booted on open source drivers.
Tried pavucontrol that sometimes muted and no way to reactivate. Tried sudo alsamixer, shows speakers color but no sound. (Although speaker L and R singularly show nothing, they stay on zero). No headphones either (which would be fine if they only worked those)

For kernel 5.10 I tried a debian one but same issue.
This is very annoying. Some guy had some files on GitHub to copy in alsa but that didn’t work either.
Don’t know what else to try, this 2on1 would run fine on arch based distro with only 2gb, a chance lost for a Linux saving an old little machine

Hey giukas, this is beyond my knowledge but I hope you find a solution. As you say, it would be good to prolong the life of that machine. Don’t give up hope just yet. Holding thumbs for you :slight_smile:

Thanks I appreciate

1 Like