No sound from laptop's speakers

Hello. I’m trying to get sound working on this Asus laptop following some of the threads here on the forum, and so far I’ve been out of luck. The headphone jack and internal mic are both working. Everything is up to date.

inxi -Fazy

Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=52a5605e-9fed-46ef-be85-d89e63cf4775 rw quiet apparmor=1
security=apparmor resume=UUID=03509a72-676d-49c1-b15a-24990c49cdf7
Console: tty 2 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
Type: Laptop System: ASUSTeK product: ROG Strix G512LV_G512LV v: 1.0
Mobo: ASUSTeK model: G512LV v: 1.0 serial:
UEFI: American Megatrends v: G512LV.310 date: 07/13/2020
Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
chip ID: 8086:06c8
Sound Server: ALSA v: k5.8.18-1-MANJARO

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

dmesg | grep snd

[ 1.588943] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[ 1.588959] snd_hda_intel 0000:00:1f.3: enabling device (0004 -> 0006)
[ 1.907879] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 2.085703] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[ 2.085705] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 2.085707] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 2.085708] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 2.085709] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 2.085710] snd_hda_codec_realtek hdaudioC0D0: Headset Mic=0x19
[ 2.085711] snd_hda_codec_realtek hdaudioC0D0: Internal Mic=0x12


Switch to another kernel. That one is EOL.

ok, I have installed and booted
Situation is still the same regarding the sound.

See this bug report and see if it helps

Are you dual booting with Windows? Disable fast boot from it.

Other Asus models with the same Audio card seem to have some solutions

A post was split to a new topic: Llenovo G51 sound question

I am indeed dual booting with Win, and I’ve disabled fast boot but no change. I’d like to mention that I’ve had Manjaro as the single OS and there still wasn’t any sound from the speakers. Both OS’ are setup on different drives. Manjaro was first, and when I installed Windows I physically removed the Manjaro drive.
I am now trying the solutions from the links, hopefully I’ll get somewhere.
1st link: crated the file alc294-sound-patch.fw and pasted content, added option in alsa-base.conf, rebooted, still no sound. I’ve undone it and rebooted again.
2nd link: booted into Win and shut down while pressing shift, booted back into Manjaro, did sudo alsactl init, still no sound
3rd link: kind of similar to the 2nd, but I won’t remove the sound drivers from Win since I’ve already had Manjaro as the only OS
4th link: tried hdajackretasking , mapped the internal speaker to the headphone jack. still no sound.
I’ve checked alsamixer periodically to make sure nothing is muted.


I’ve found a semi-solution, however the speaker’s volume can only be changed by adjusting PCM in alsamixer. Changing master volume does nothing for the speakers, only mute them if it’s 0.


add line and reboot.

options snd-hda-intel model=asus-zenbook