No sound fresh install (latest) w/Razer Nari headset


I recently (last week) downloaded and installed the latest Manjaro XFCE edition, and everything is working well except that I have no sound. Install was done on a desktop PC with a realtek audio (soundcard included on the MB) and my output device is a Razer Nari Ultimate headset.

Things I have checked so far:

  1. pulse audio detects there is a stream of sound coming from FireFox and the headset is recognized however there is only mono output/input available.

  2. alsamixer shows the realtek sound card (auto mute is disabled) but it is not default. Selecting this as the sound card has no effect.

  3. The Razer headset is also listed as a sound card but only has one option (master volume).

  4. I re-installed/updated sof-firmware which did not change anything.

  5. Nothing seems to be muted anywhere except my microphone.

  6. Tried a non USB or wireless headset (normal headphone jack) and was able to select the non USB headset and get sound through that but not through the Nari Ultimate.

  7. I did not find any Razer specific software (other than for mice) in the package manager.

Any help would be appreciated. I’m probably overlooking something simple as I’ve used Manjaro previously on this same machine (Gnome version) and sound worked out of the box.

Thanks in advance for any help!

provide output from:
mhwd-kernel -li
inxi -xA