No sound, but only from one of the soundcards

Yesterday I have turned on my laptop and found out that I get no sound from my soundcard.
The symptoms of the problem are:

  • KDE shows the device as normal, even the sound level indicator goes up and down while playing music

  • Every application sees this device as normal

  • I can control the volume as same as before, but no sound

  • The sound works just fine on the other soundcards

What I have tried

  • All the classics: Replugging the jack

  • Reseating the soundcard (since it’s a part of a USB-C docking station)

  • Restarting the pulseaudio

  • Rebooting the whole laptop

  • Playing sound from another OS (on Windows 10 worked without problems)

If you guys have any idea what might cause this, I would strongly appreciate any kind of response as same as I can provide any additional logs of my system.

KDE 5.21.5 on Manjaro 21.0.7

One thing I noticed is that in alsamixer under the device name it only shows the capture, but not the playback part of the device. The forum doesn’t allow me to post the image here, but I hope it’s clear for everyone what is happening

So… Thanks everybody for their response :smiley:

For those who could have the same issue, here is my fix:

I am using HP 455 G7 laptop with DELL WD15 dock. After booting up the live version of linux being ready to reinstall the whole system I noticed the audio wasn’t working either. So what I did is I first unplugged the USB-C cable from the laptop and then unplugged the dock from it’s power (My speakers connected to the dock popped a bit). Then I reconnected the power adapter back to the dock and then the UCB-C cable back to the laptop. Then I did a reboot and everything seems to work fine somehow. It’s quite strange, since I have completly changed the settings of pulseaudio, but it seems to work just fine, so as long as it’s working I’ll leave it like that.