No sound after upgrading kernel 5.11.2-1

I’have successfully installed arm on a S905x3 Max+, but after upgrading, the sound doesn’t work. My dtb is MESON-SM1-X96-MAX.DTB. I’ve tried systemctl enable sound --now but no effect.
Any idea ? Any other dtb?

Hi @eduborsa,

Does the sound work with other kernels? Like 5.10, or 5.4? Which are the LTS kernels.

Yes It worked whith the previous kernel, I think it was 5.10. I haven’t tried 5.4.

Considering 5.10 is an LTS version that will be supported way longer than 5.11, why don’t you just stick to that, then?

How can I downgrade de kernel?
I’m new in Manjaro.

you have options in system settings

I have installed the last version of Khadas Vim 3 kernel 5.11 in my S96 Max+ 4g S905X3 but sound and ethernet don’t work at the same time.
I’ve tried differents dtb’s: meson-sm1-sei610.dtb, meson-sm1-sei610-ethfix, meson-g12a-x96-max-rmii, meson-sm1-se1610-2, meson-sm1-x96-max, meson-sm1-x96-max-plus, sm1_ac213_4g, sm1_ac213_4g, g12a_u212_4g and others.

With meson-sm1-sei610.dtb I’ve got sound but no ethernet. With meson-sm1-sei610-ethfix or meson-sm1-x96-max have ethernet but no sound.
I’ve tried to edit meson-sm1-sei610.dts and mix with meson-sm1-sei610-ethfix.dts but no success.
However, with kernel 4.9 both sound and ethernet worked well with meson-sm1-x96-max.dtb
I’ve also tried systemctl enable sound --now but no sound cards detected.

Has anybody got sound and ethernet ?

Did you tried this ?

Thanks for the dtb. I’ve tried it but the result is the same: ethernet but not sound.
When I run /usr/bin/ it doesn’t detect de sound card, however my sound card is g12AX96MAX and it works with previus kernels and the same dtb.
I wonder if installing sof-firmware and updating the kernel could it work?

To downgrade the kernel, there are 2 options:

  1. The GUI option:
    1.1. Open Manjaro Settings Manager from the launcher. (The “Start Menu.”)
    1.2. Double-click on Kernels
    1.3. On the right you can select to install a different version, or remove an installed one.
    Click “Install” for 5.10 and remove next to the current one. Provide root passwords as neccessary.
    1.5. Reboot.

You should now have successfully booted into the new (older) kernel.

  1. The CLI option:
    2.1. Open a terminal.
    2.2. We need to install the different kernel first. We already know we want to install kernel version 5.10. So in the newly opened terminal, run the following command:
sudo mhwd-kernel -i linux510

Provide the neccessary root password when prompted.

2.3. When it’s finished, reboot the computer, but it won’t boot into an older kernel version automatically, so you have to select which kernel version it should use.
2.4. To do so, when you have rebooted your PC, hold in the Shift key while it’s starting up and going thorough the BIOS checks. This will cause the grub boot loader to bee shown.
2.5. In the boot loader menu, using the Arrow keys, navigate to the “Advanced Manjaro” option, and press Enter to, well, to enter it.
2.6. On the screen that newly appeared, select the kernel version you wish to boot into, in this case 5.10. Use the Arrow keys to navigate to it, and press Enter to boot using that kernel.
2.7. If successfully booted and logged in, open the Terminal once again, we now have to remove the faulty kernel. We do this by running the following command:

sudo mhwd-kernel -r linux511

And, theoretically that’s it! If all went well, you’re now back to using the old kernel, version 5.10.

If this doesn’t work, I’m not here. Well, I won’t be here, anyway, but that’s besides the point, I think.

Thank you for the instrucctions to downgrade the kernel.
I’can’t find the Kernel application in ARM manjaro-settings-manager . I also could’nt find find the mhwd-kernel program in pacmac-manager. I think they aren’t in the ARM version.

On the other hand, I would like to have the 5.11 if I can.