No sound after update (pipewire, xfce)

I just did an update to my XFCE Manjaro and my sound is gone (using Clementine, hydrogen, MPV). Hydrogen doesn’t work in pulseaudio, jack anymore, also tried ALSA but nothing. I recently switched to Pipewire and things were working fine. I can see bobbers going up and down in pavucontrol (should I still be using that?). The profiles look good as I turn HDMI audio off and use device 2 (snd_hda_intel) which is set to “Pro Audio” which was working fine before. I tried changing to all the recommended kernels because sometimes in the past that helped. Currently I’m running 6.1.23-1-MANJARO which is the latest recommended one.

Only clue I have is from the first answer of this:
It says “[…] Either switch to pipewire-media-session and keep pulseaudio […]”. Well pulseaudio is uninstalled but pipewire-media-session is still there. I try to remove it but there is a dependency chain leading to the metapackage manjaro-pipewire so I don’t know what to do now.

$ sudo inxi -A
[sudo] password for sawdis: 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.1.23-1-MANJARO status: kernel-api

Can you post the output of alsamixer ?

I can’t post output in the terminal. However I went into alsamixer in terminal and changed to 3rd sound device (the one I want) instead of the default 1st one. The front speakers were muted so I unmuted them. So I got sound working… except when I reboot I have to go and unmute it again. I wonder why it keeps muting my front speakers on boot in alsamixer… and how come pavucontrol pretends that everything is fine when it’s not?

You can store/save the settings in alsamixer.

I setup the volume levels. Then:

$ sudo alsactl store
$ cd /etc/systemd/system/
$ vim alsa-restore.service 

Description=Reboot alsa store systemd service.

ExecStartPre=/bin/sleep 10
ExecStart=/usr/bin/alsactl restore


Got it from here but I think they made a typo with the =-/usr/blahblahblah I think there should be no hyphen there.

Not sure this “sleep 10” thing could work. 3 reboots and had 1 failure and none of them did a slow fsck at boot time.

Since the systemd way is intermittent (race condition?) I just bind a key using XFCE keyboard setting to run command:

amixer -c 1 sset Front toggle

where card 1 is the card I want. It’s just a workaround.

Is there no better way? I have tried removing the delay and trying in the [unit] section:
and also:
but it doesn’t work. Also tried making the delay 20 seconds but it didn’t work.

I changed a line in alsa-restore.service to look like this:
ExecStart=/usr/bin/alsactl --file ~/.config/asound.state restore

Before that I did an alsactl --file ~/.config/asound.state store with the correct settings. Manjaro was randomly overwriting the default file (or maybe only the latest update I did today?). I still wish I didn’t have to use a delay.