No sound after packages update

Hello, gentlemen,

I have updated my packages using pacman -Syu today. I have also removed orphans packages. After rebooting, I noticed that no sound was coming out of my computer, whatever the speakers I was using.

As you can see, in the system configuration panel, the audio output is flagged as “inactive:”

Here are my Alsa informations.

Pacman logs for packages upgrade.
Pacman logs for removing orphan packages.
pactl cards informations.

Kernel: 6.6.32-1-MANJARO, DE: Plasma 6.0.5.

Restart PulseAudio . Then, ensure your audio services are running and enabled:

pulseaudio -k
pulseaudio --start

Now, verify your audio services are active:

systemctl --user start pulseaudio
systemctl --user enable pulseaudio

Maybe that already works.

Thanks for your answer. I tried all the commands you gave. Pulseaudio is running well:

$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; enabled; preset: enabled)
     Active: active (running) since Tue 2024-06-18 16:14:38 CEST; 37s ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 7688 (pulseaudio)
      Tasks: 9 (limit: 9376)
     Memory: 17.1M (peak: 17.6M)
        CPU: 793ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─7688 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─7696 /usr/lib/pulse/gsettings-helper

juin 18 16:14:38 xxxxx-hplaptop15da0xxx systemd[897]: Starting Sound Service...
juin 18 16:14:38 xxxxx-hplaptop15da0xxx systemd[897]: Started Sound Service.

However, the sound is still not emitted by the speakers.

Okay, so then lets put that a little further… (but BEFORE… just to make shure that it is not a simple little bug… do a complete reboot again) - sometimes that already helps. And do a complete “cleanup” after the update: Manjaro System Maintanance

If this does not help - follow up with these steps:

Check your audio levels in alsamixer to ensure nothing is muted. Run alsamixer in the terminal and use the arrow keys to navigate and adjust volumes. Ensure that the master and speaker channels are unmuted and set to an appropriate level.

Next, verify the sound configuration by running the following commands to list and test the playback devices:

List all sound cards and their details: aplay -l

Then test the sound output: speaker-test -c 2

Your pulseaudio service appears to be running without issues to me. Here are some additional troubleshooting steps:

  1. Check the output devices in PulseAudio:

Open pavucontrol (PulseAudio Volume Control) and ensure the correct output device is selected and not muted.

  1. Recreate PulseAudio configuration files:

Sometimes corrupted configuration files can cause problems. Try resetting the configuration files:

  • Remove the PulseAudio configuration directory: rm -r ~/.config/pulse

  • Restart PulseAudio: pulseaudio -k followed by pulseaudio --start (as you learned already above)

  1. Test audio output with ALSA:

To ensure it’s not a PulseAudio-specific issue, test audio output directly with ALSA:

  • Play a test sound: aplay /usr/share/sounds/alsa/Front_Center.wav

  • Check log files: Inspect PulseAudio log files for errors. You can do this with journalctl: journalctl -xe | grep pulseaudio

4. Fallback to ALSA:

If all else fails, temporarily disable PulseAudio and use ALSA to see if the issue is resolved:

Stop PulseAudio: systemctl --user stop pulseaudio
Test with ALSA: speaker-test -c 2

Let us know of the results of these steps. - Hope that helps. Cheers

1 Like

I installed pavucontrol, changed the output device a few times and it ended up working. The outputs are no longer disabled in the sound configuration panel. Thank you!

1 Like

Awesome, perfect! You’re Welcome :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.