No Sound after Installation Front Detection?

Hello everyone! I am new to Linux & Manjaro :slight_smile:
So I was using Windows 11 and replaced it with Manjaro now everything works fine besides that I have no sound? It seems like my headphones doesnt get detected I had the same issue on Windows BUT on Windows I found a workaround inRealtek Audio Console disabling the “Disable Front Detection” and then everything was working fine. Any idea how to fix this here on Plasma? Ty :smiley:

1 Like

Note: When plugging in the Headphones at the back of my PC everything works fine

Welcome to Manjaro forum @RaphaelDeck

To disable headphone jack detection:

Find the audio card number for the onboard audio analog output from:

aplay -l

(most likely to be either card=0 or card=1)

Then install alsa-tools package

pamac install alsa-tools

Run jack-detection tool with headphones plugged in and unplugged

sudo hdajacksensetest --card=0

If responses show: (Green Headphone, Front side): present = No even when headphones are plugged-in, run the jack re-tasking tool:

sudo hdajackretask --card=0

Enable Advanced override and Override for the Green Headphone, Front side jack

Change Jack Detection to Not Present and click on Install boot override

Reboot system to load jack override

This show in my console “Command not available” even after installing the alsa-tools

typo error, should be:

sudo hdajacksensetest --card=0
1 Like

Worked perfectly thank you so much! Now I can begin exploring Linux for the first time :smiley: Ty for the fast help!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.