No sound after fresh install (no mute problem)

I just installed manjaro linux KDE, and there are absolutely no sounds. I tried un-muting several times and following several tutorials, including this one: doc. ubuntu-fr. org/ audio_intel_hda (had to put spaces otherwise I couldn’t sent the message) but it doesn’t include my laptop. My laptop is a testing laptop from the french brand Unowhy, and it is not even in the market so I’m not surprised it isn’t in that list.

If that helps, the output of lspci | grep -i audio:

00:1f.3 Audio device: Intel Corporation Comet Lake PCH-LP cAVS

However, when I plug in my USB headset, everything works perfectly. I had the same issue on all linux distros I tested (pop os, ubuntu KDE, manjaro gnome and the one I’m currently using, manjaro KDE)

Thanks in advance !

What is the output from the command inxi -Aa ?

What kernel version (could use uname -r )?

Looks like it should be detected by 5.3 or later

In this thread issue was solved by adding line to /etc/modprobe.d/alsa-base.conf

Output of inxi -Aa:

Audio:     Device-1: Intel Comet Lake PCH-LP cAVS driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
           bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.32 running: no 

Output of uname -r:


So it should be detected…
I already tried that thread, it didn’t work (even after restart)…

Via this thread with Comet Lake problem

suggests this thread’s solution



to line in grub config

what/where is the grub config ?

dmic_detect=0 to disable internal digital microphones was deprecated last year and would not work for kernel v5.10 or later on Manjaro. Older v5.4 kernel is not likely to work well on brand new hardware

inxi is showing an onboard audio device is detected and drivers loaded

@Bananasmoothii please post more ALSA information

sudo --upload

you may need to use </> preformatted text to post an inactive url to the data to avoid any problems with the forum spam filter

1 Like

Here it is:

My microphone works well tho…

PS: I reinstalled Manjaro in the meantime so there might be some differences

Hello again, I installed windows in dual-boot and hade the same problem, a friend of mine told me to try that and it worked perfectly

1 Like

working on Windows but not Linux?

Yes, after installing the thing I linked above, sound worked again on windows.

I could not find out much about Unowhy and nothing at all about this audio codec from the vendor ID and subdevice ID

I suggest you install v5.13 kernel that may detect audio device correctly
use either Manjaro Settings Manager GUI - manjaro-settings-manager -m msm_kernel
or this command

sudo mhwd-kernel -i linux513

If a later kernel does not help you might be able to get information about the working audio codec configuration using this guide:
How to sniff verbs from a Windows sound driver · ryanprescott/realtek-verb-tools Wiki · GitHub