No signal on display after booting from initial installation


I’ve recently built a new PC with an AMD 7800 X3D and my old Nvidia GTX 1080Ti. This runs on an Asus B650E-I motherboard. I’m trying to dual boot Windows 11 Pro and Manjaro Linux.

I’ve finished installing Windows, so I went ahead and tried to install Manjaro KDE, I got the latest version with kernel 6.9. I tried to boot with properietary drivers, as I would like to use them. It did boot, but the screen resolution was locked at 1024x768, which was strange. I still went ahead with the install.

The installation worked and I am able to get to the grub menu. However, when I start Manjaro, the screen goes blank. The monitor reports no signal. I cannot switch to a text console, so I can’t really run any updates or configure my system. What should I do now?

Make sure Fast Boot and Secure boot is turned off in that BIOS/UEFI as well as Windows itself.

So, I suppose what you meant was something more like:

Make sure Fast Startup is disabled in Windows (powercfg /h off from an elevated command prompt) and that Fast Boot and Secure Boot are completely disabled in BIOS.

That was it, right? :slight_smile:

That was, indeed, correct. But I can never remember what’s it called in Megasuck…

1 Like

Well I made sure that fastboot is disabled in windows

On my UEFI settings though, to disable secure boot it’s not very clear. I have two options: “Windows” and “Other OS”. It is set to Other OS.

Anyway, I am pretty sure manjaro is booting, because if I press ctrl alt delete after the black screen, it does restart. But I’m still getting a blank screen so I can’t tell for sure. I really think it’s a video settings issue

The other option would be to boot into a live environment, enter a chroot environment from there, and inspect the last boot’s logs.

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Finding errors for specific boot

journalctl --priority=warning..crit --no-pager --boot=-1


  • The --priority=warning..err argument limits the output to warnings and errors only;
  • and the --no-pager formats the output nicely for use here, on the forum;
  • the --boot=-1 argument limits the output to log messages from the previous boot. This can be adjusted to -2 for the boot before that, -3 to the boot before that, and so on and so forth.
1 Like

With some BIOS implementations, you need to delete the keys to disable Secure Boot. They are recreated if/when it’s enabled again.

Windows/Other OS usually has nothing to do with Secure Boot. In your BIOS, it indicates OS type.

What you need to look at is below that, under Secure Boot Mode and Key Management. This guide from ASUS may be helpful, and shows that the keys must be cleared to disable Secure Boot.

Perhaps more information about your system might also be useful:

inxi --admin --verbosity=8 --filter --no-host --width


1 Like

I tried this, but manjaro-chroot does not detect my installation. This is probably because I’m using btrfs. I feel like I’ve gone down this road on my old PC, but I can’t remember what I did… I guess the next step is for me to chroot manually into the root subvolume. However, I’ll need to hunt down for instructions. Will post again if I get stuck. Thanks for the help.

I followed the guide, cleared all the keys. Windows still is able to boot, and I was able to confirm that Windows reports that secure boot is disabled. At this point I really don’t think this is a secure boot issue. Thank you for the help, because I wasn’t sure initially.

That is very relevant information. BTRFS needs has specific way to chroot.

Perhaps @Aragorn or someone that knows more about btrfs, like
@andreas85 can help.

I can give you the instructions on how to chroot into a stock btrfs install, but I have no idea with regard to the OP’s graphics problems. :man_shrugging:


Most welcome.

A reminder that if Secure Boot was still enabled; and as Manjaro does not support Microsoft’s Secure Boot implementation being enabled; Manjaro would have simply not been able to boot.

So, this was a valid point to verify.


This time i am late :wink:

How to chroot with btrfs



Thank you for this, I am able to chroot into my system now

Looking at the logs, I noticed the following:

  • It’s detecting an AMD GPU in addition to my Nvidia card. This is probably the integrated graphics, which I’m not using. I noticed this GPU also getting detected in Windows. I don’t know if this would pose a problem.
  • It seems to be using opensource drivers for the nvidia card. I get the following error, after nouveau initialization: DRM: DDC responded, but no EDID for DP-1. So it would seem that it doesn’t know how to set the resolution based on information from the monitor. But anyway the fact that it’s using opensource drivers is enough to let me know where the problem is

I went into the chroot, used mhwd to install the properietary nvidia drivers manually. I followed this guide: Configure Graphics Cards - Manjaro and ran the following command in the chroot

sudo mhwd -i pci video-nvidia

After that, I rebooted… and I was able to boot into a nice GUI desktop without issue :slight_smile:

Thank you everyone for your help!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.