No signal after RX 6800 XT installation (however BIOS works)

Hello everyone,

after following instructions as described in:

… and installing my new 6800 XT into motherboard, I ran into a problem; I just cannot boot into Manjaro anymore. 6800 XT seems to be working fine to an extent that I can see BIOS, modify boot sequence etc. but after that it just wont’t give me my Plasma anymore. It does not even give black screen or any error message, it tends to boot as usual and then my monitor suddenly returns “There is no signal on DisplayPort or HDMI, going into standby”.

How should I proceed now? I tried to boot up the latest Live ISO of Manjaro, but it won’t give me Plasma neither, it fails on " Failed to start Simple Desktop Display Manager" and not even manual “startx” from tty did the trick, it just won’t show any GUI whatsoever.

I also tried to chroot into my current installation of Manjaro via this Live USB running, I tried to rebuild linux-headers for Kernel 5.9, also ran updates and then did remove video-linux as well. Then rebooted and still no signal. So far it seems to be hopeless, any ideas as to what I should try next? Do you think this is a hardware issue? Yet how is it possible then that I can see BIOS via my DP or HDMI just fine, also Live USB seems to be able to give me at least tty fine without much issues so that I can chroot into my current installation of Manjaro from it.

Any help MUCH appreciated, for now I will continue searching for answers via Google as usual. Thank you a lot in advance!

Allright, so after POST I pressed Shift couple of times and managed to edit my startup script for Manjaro. I replace “quiet” option with “nomodeset” and now I can see at least that the error is caused by:

“Failed to start Simple Desktop Display Manager”

Also tty now works fine, so that definitelly helps with debugging what is actually wrong.

Still cannot proceed to GUI as usual, but I’m getting closer. Any help much appreciated!

I recently had exactly the same problem with my 5700XT. The problem was with the modified BIOS provided by ASUS. The new GPU BIOS is incompatible with any kernel version, forcing the display manager to not start with an error about a missing display.

If your card has a second BIOS switch, try changing to it. Unfortunately we are going to many of these problems over the next few months. My 5700XT was unusable for the first two months I had it.

I replied in similar topic that I also created when trying to get this RX 6800 XT working, long story short I swapped it with nVidia RTX 3080 and went with proprietary drivers as usual. They always work for me just fine so that is my solution, however like I said elsewhere I will try to switch again with introduction of RDNA3 GPUs sometime in near future, so by no means am I giving up on AMD. I like that particular piece of hardware, it is just the software part which did not impress me at all. But at the same time it is way too soon maybe and things will iron out in next weeks, however I’d much more prefer to go with nVidia right away then which guarantees me no issues at all when running proprietary driver suite.

Thanks for suggestion anyways, may come in handy in future.