No secrets wired ethernet

Changed internet provider. Have a five way switch POE direct to router. No vpn. I have a working internet on Mac G5 and a win8.1 both connected to the switch and they worked both worked before changing service providers and after. However my Manjaro Sikarisi 22.0 had internet before changing providers, but now I get “no connection wired connection deactivated”
“wired interface (Eno1) No secrets were provided. (yellow triangle warning).”
I have switched back and forth between these same two providers before, Spectrum and AT&T with no problems getting a connection This time going back to Spectrum I’m at a loss understanding “the no secrets were provided message”.
I went through the Connections-Systems Setting Module and found no reference to no secrets. I do not use Kwallet btwy.
I would appreciate any words of wisdom. I am a noobie. Thanks in advance for any help.

panel right side: Networks :: manage connections
delete Eno1
create a new wired ethernet connection

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.