No puedo actualizar ni instalar, /etc/pacman.conf no pudo ser leído: No existe el fichero o directorio

Hola, soy totalmente nuevo a Manjaro, ayer mismo instalé ManjaroXFCE 32 bit 18.0.4 y tuve problemas.
Empezando con que quería instalar una aplicación (como ejemplo, Rhythmbox) desde el Gestor de paquetes, me soltó un mensaje que decía
"No se pudieron satisfacer las dependencias:

Incapaz de satisfacer la dependencia ‘pacman>=5.2’ requerido por ‘pamac-common’
Incapaz de satisfacer la dependencia ‘pamac-common’ requerido por ‘pamac-cli’
Incapaz de satisfacer la dependencia ‘pamac-cli’ requerido por ‘pamac-gtk’ "

Busqué cómo podría solucionar esto y me encontré con una página que planteaba un error parecido, decía que el problema puede ser por un problema de dependencias de un paquete (en este caso package-query). La solución consiste en remover del sistema el paquete en conflicto y todas sus dependencias.
Hice el primer paso y me salió

Solo seguí el primer paso y hubo otro error:
/etc/pacman.conf no pudo ser leído: No existe el fichero o directorio
Fue aquí cuando me cansé y apagué la laptop.
Ahora, según el gestor de archivos, estoy actualizado (pese a que no descargué nada) pero ahora no me aparece ningún software para instalar (como rhythmbox).
Después active lo de AUR y me pide actualizar 42 elementos, pero al hacerlo me dice

“Falla al sincronizar las bases de datos”

La verdad es que no pido mucho para esta Notebook, sólo la quiero para usar LibreOffice, cambiar a Firefox porque Midori es muy lento y videos.
:slightly_frowning_face:

Hola mond y bienvenido al foro.

¿Estás seguro de necesitar la versión de 32 bits? Lo digo porque ha dejado de mantenerla el equipo de Manjaro y ahora se encarga de ella la comunidad. Mi CPU es de 2008 y funciona a 64. Para asegurarnos ejecuta este comando en la terminal y publica su resultado:

lscpu

También deberíamos asegurarnos de que el archivo /etc/pacman.conf existe y tiene contenido con:

cat /etc/pacman.conf

Muchas gracias por contestarme!

Busqué el /etc/pacman.conf como sugeriste y me puso que no aparece.

cat /etc/pacman.conf
cat: /etc/pacman.conf: No existe el fichero o el directorio

Y con lo segundo ¿te va bien, no se traba o algo? porque si tu CPU es del 2008 y funciona a 64, puede ser que el mio tambien.

lscpu
Arquitectura: i686
modo(s) de operación de las CPUs: 32-bit, 64-bit
Orden de los bytes: Little Endian
Tamaños de las direcciones: 36 bits physical, 48 bits virtual
CPU(s): 4
Lista de la(s) CPU(s) en línea: 0-3
Hilo(s) de procesamiento por núcleo: 2
Núcleo(s) por «socket»: 2
«Socket(s)» 1
ID de fabricante: GenuineIntel
Familia de CPU: 6
Modelo: 54
Nombre del modelo: Intel® Atom™ CPU N2600 @ 1.60GHz
Revisión: 1
CPU MHz: 789.721
CPU MHz máx.: 1600.0000
CPU MHz mín.: 600.0000
BogoMIPS: 3192.63
Caché L1d: 24K
Caché L1i: 32K
Caché L2: 512K
Indicadores: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts nonstop_tsc cpuid aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dtherm arat

Pues dentro de lo que cabe, mi CPU va bastante bien:

CPU:
Info: Quad Core model: Intel Core2 Quad Q9650 bits: 64 type: MCP L2 cache: 6144 KiB
Speed: 2000 MHz min/max: 1998/2997 MHz Core speeds (MHz): 1: 2000 2: 2000 3: 2548
4: 2743

Según la información suministrada por tu procesador soporta instrucciones de 64 bits:

modo(s) de operación de las CPUs: 32-bit, 64-bit

Así que te recomiendo que instales Manjaro con arquitectura de 64. Además, la reinstalación solucionará el otro problema.

Te recomiendo que utilices MX Linux o Antix, ambos vienen de 32 bits y reciben actualizaciones.

Tengo una netbook con ese mismo procesador, 4gb de ram y un SSD. Intente instalar sistemas operativos de 64 bits pero no funciona, si bien arranca el grub y demas, a la hora de iniciar el sistema operativo no pasa nada, queda la pantalla negra.
Segun lo que lei por ahi se puede migrar desde ese Manjaro que vos tenias a Arch, hay que modificar algunas cosas. Yo no logre hacerlo ya que hay un problema con la claves o firmas pgp y demas, tampoco consegui instalar Arch de 32 bits por el mismo problema, ni siquiera pude instalar el paquete “base”.

ESTOS ERAN LOS PASOS PARA MIGRAR DE MANJARO32 A ARCH32:

Get a new mirrorlist

https : //git . archlinux32 . org/packages/plain/core/pacman-mirrorlist/mirrorlist

edit pacman.conf

remove manjaro-system from HoldPkg line
remove SyncFirst line (manjaro patch)

Follow instructions from Transition … section at https : // www . archlinux32. org/download/

Accept package replacement/removal when required

sudo pacman -Syy archlinux32-keyring-transition
sudo pacman -S archlinux32-keyring

Remove conflicting packages:

sudo pacman -Rdd pacman-mirrors manjaro-system manjaro-release bashrc-manjaro libxxf86misc menulibre

Install Arch pacman and pacman-contrib:

sudo pacman -S pacman pacman-contrib

Remove:

sudo pacman -Rns manjaro-settings-manager manjaro-settings-manager-notifier

Install - fix two conflicts:

sudo pacman -Syu base linux linux-headers filesystem grub sudo systemd systemd-libs systemd-sysvcompat xorg-server xorg-server-common xorg-server-xwayland --overwrite ‘/usr/include/crypt.h’ --overwrite ‘/usr/lib/libcrypt.so’

Build initramfs:

sudo mkinitcpio -p linux

Remove manjaro kernel (remove any dependencies - like drivers - remember to install opensource drivers if necessary)

sudo pacman -Rns linux414

Update grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Todo esa info lo saque de aqui:

nix. dk /notes-and-bookmarks/convert-manjaro32-to-archlinux32

Si no tienes idea de como hacer el cambio a Arch:

youtube . com/ watch?v=eH9VAyZlCe8

1 Like

Tuve que poner todos los links separados porque esta cosa no me los permitio pegar.

Espero y te haya sido util mi comentario.