No previews on desktop

the file previews in icons are not working on the desktop even tho they work inside Dolphin.
I have tried restarting plasmashell. rebooting. turining icon previews off and back on but none seems to resolve this.
Is this a new bug common to all in kde 5.24 or just me?
Any help would be much appreciated.
Thank you.
here’s a screenshot showing previews working in dolphin but not on the desktop.

Right click on the Desktop > Icons > Show Previews.



I have tried that but it didn’t work for some reason.
thanks anyway.

Have you also set the flag at Right click on Desktop > Configure Desktop and Wallpapers > Icons > Preview thumbnails (also check the flags in Configure Preview Plugins)

yes i did do that. I tried timeshift and restored a week old snapshot and it still didn’t fix it. I can’t figure out what is causing it at all.

Normally these 2 suggested settings actually should be the same and should sync but I also had a minor glitch where the Show Previews on the desktop did nothing anymore. After I went into the second setting suggested here it went back to normal, probably also after I rebooted.

Have you tried to clear the user cache?
To my knowledge the respective setting is in ~/.config/plasma-org.kde.plasma.desktop-appletsrc
after lines previewPlugins=
If previews=false there is a line in the file. If previews=true which is default the line is missing
I suspect in your case that activation and deactivation is set accordingly in the flat file and that it’s something else almost certainly related to your user session.

Edit: 2 more options I can suggest if clearing cache didn’t help: reboot with ‘Start with an empty desktop session’ or test with a newly created second user if it behaves the same

I checked that file, none of the lines you menioned appear there. should i add them? If i should would you mind copying pasting the lines required from your ‘plasma-org.kde.plasma.desktop-appletsrc’ file.

how do i do that? should i delete the ~/.cache folder entirely or is there some special way to do is from systemsettings? The folder is quite big so i am not sure if it is safe to delete.

I will do that as soon as I can and post my results.

Thank you very much for your help. It is much appreciated.

No worries, but first things first. The easiest way to clear user cache is in terminal

rm -rf ~/.cache/*

If you prefer a GUI program you may install BleachBit program. It has a section System>Cache and with the Preview button at the top left you can simulate deletion first and gives you a list of files to be deleted. Note, BleachBit won’t be able to delete some files currently in use. Generally it’s safe to delete cache files, although they contain some useful information for the user session.

Below is the most basic sample config for the file for reference. You might have more parameters for this statement. I added the previews=true line which is in default ommited/ not existent because it’s assumed default state. Also note that the number between Containments and General might need to match other Containment General parameters of your file.


Adding this will not have immediate effect. You will have to restart plasmashell in terminal or relogon

killall plasmashell && kstart5 plasmashell

My suggestion: Clear user cache first, do a logout and log-on and if it still persist create a second user and test if the problem also exists there.

clearing the cache or adding the lines to the file didn’t work but a new user accout does work. So there is hope. I’m suspecting one of the desktop wallpaper addons or other stuff i used for customizing may be causing this issue. I will try to customize the new user to the same as my current account and check step by step to identify the culprit.
Thank you very much you have been very helpful. :grinning:

1 Like

That’s good news! I saw the heavy customization of your desktop :)).
One last thing to try, after that I am out of suggestions:
System settings > Startup and Shutdown > Desktop Session > When logging in: Start with an empty session.
I hope you can resolve this issues!

nothing worked :frowning:
I tried everything. Ultimately I went nuclear and starting going back in time with timeshift one back up at a time. The thumbnail bug did fix itself once i went all the way back to week 3 on 20th February. I was pretty happy. Then I used my pc for a bit restarted a couple of times just to make sure it was fixed for sure.
However, just as soon as i ran the system update ( it also included plasma 5.23.5 to plasma 5.24.2) and restarted the thumbnails (previews) were gone again. I guess I’ll just live without it. Maybe the next update will fix it. I will update the forum post if possible after the next update.

Anyway, thanks for all your help and support.

P.S: I guess I could still create a new user and copy my home folder to that user but I am done for this week i guess, too much effort for some thumbnails.

Again, thank you very much for the support and your time.

@laddupeda That’s unfortunate to hear.
Question: Timeshift is not configured to backup your /home folder, is it?
Also according to logic I think you shouldn’t be able to change icon size on desktop either. It’s the same config.

I am thinking it must be related to some ~/.config/ files that’s preventing plasmashell to read or update the settings.

Should you still want to dig deeper I am thinking about:

  • Theme or widgets config overwriting/preventing standard settings, maybe minor incompatibility
  • When was the theme being last updated by the creator? (code changes)
  • May a potential reinstall of theme and other desktop elements help?
  • What about reverting back to Manjaro Breath theme?
  • Maybe try again with timeshift: Apply the system update by logging out from user and run the update in TTY, clear cache, reboot, logon

It’s probably too much work to reconfigure everything. Decide for yourself, how much time you want to invest in it :wink: .
Of course, migrating to a new user is an option.

1 Like

OK, maybe I will try moving the folders and files out of the .config directory and try to figure out which one is at fault, when i get some free time.
Thank you as always :slight_smile:

It was actually the latest 5.24 plasma update.
They did something that doesn’t show thumbnails/previews if the folder is not on the home partition.
I actually have my Desktop, downloads, music etc ‘places folders’ deleted and replaced with links to folders of same name on another partition I use for storage.
Thumbnails use to work for links too in 5.23 but stopped working with update to 5.24. I confirmed this twice by using timeshift to downgrade to 5.23 and then upgrading to 5.24.
The desktop icons/previews works perfectly as it should if the Desktop folder is a “real folder” on the home partition and not a link to another folder in another partition.
This also applies to dolphin.

Here’s a screenshot.

here you can see, Dolphin shows previews for the ‘OBS’ and ‘tmp’ folders which are actually located on the home partition but not for the Desktop or Downloads folder which are links to another folder in the storage partition.

Here’s a screenshot with desktop icons with previews not working when the ‘Desktop’ folder is a link.

And here’s a screenshot where the desktop previews start working as soon as I replace
the link with an actual folder on the home partition.

see how the folder icon in dolphin also shows previews inside it now.
I hope they fix it in 5.25

PS: about the different wallpapers and widgets, those are two different activities I use for studying and web browsing/other stuff.

I am glad that figured it out.
Since you did explain the core issue with ‘external folders’ I remembered another thread here in the forum about Dolphin previews not showing for external folders.

Hopefully I have the solution for you that also works in your case:

Go to Dolphin > Configure > Configure Dolphin > General > Previews > Skip previews for remote files above > Set it from ‘No previews’ to e.g. 100 MB

I tested this with an external SSD folder and it worked, I got the previews on the desktop. You have to logout and relogon after you change the setting (or restart plasmashell maybe). Please try.

Here is a screen:


My man you did it. Thank you so much.
The “in-icon previews” for the folders don’t work but they weren’t very useful anyway.
The desktop icons show previews now and I can not thank you enough. It’s been bugging me for a while.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.