No PDF Previews in Dolphin


I tried to see if I find this elsewhere but so far it looks like my problem is different. I probably managed to mess up configuration somewhere but I cannot find it.

Preview in Dolphin seems to work for all file types except PDF. Here is a screenshot demonstrating it:

I’ve checked the previews setting in Dolphin which looks correct to me, I also clicked on the “Defaults” button in the settings to see if I could reset something. I have no limit for preview file size. I’ve checked that kdegraphics-thumbnailers is installed. I’m a bit out of ideas, so throw your thoughts my way please :slight_smile:

And of course, as always, my apologies if this has already been solved elsewhere. I tried to do some searching here on the forums first (and general KDE searches), but nothing solved it for me that I found.

What you could try is the following… Log out of Plasma completely and log in (as yourself) at a tty ─ press Ctrl+Alt+F2 to get to a tty. Then, enter the following commands… :arrow_down:

rm -f ~/.cache/*.kcache
rm -f ~/.cache/Dolphin/*

Then, log out of the tty ─ just press Ctrl+D and return to the SDDM login screen with Alt+F1. Log in again and see whether that made a difference.


Thanks, that’s definitely not something I would have come up with by myself. Unfortunately didn’t do the trick. Still no PDF preview, while all other files I have checked show preview as expected (even things like *.NEF/Nikon raw).

Just for giggles, what happens if you do set a maximum file size for previews? You can set a large one, like e.g. 20 MiB.

I had set it to 50MB earlier, forgot to mention that. Tried to set it to various limited numbers now, still no success.

Well, it was worth a shot, because on my system here, I have it set to 20 MiB and I do see previews for PDF files. :man_shrugging:

Hi @yngvel,

According to this answer it has something to do with the kdegraphics-thumbnailers package.

So check if that’s installed:

$ pamac search kdegraphics-thumbnailers
kdegraphics-thumbnailers                                                                                                                                                            [Installed] 21.08.2-1                 extra
Thumbnailers for various graphics file formats

And if not, install it:

pamac install kdegraphics-thumbnailers

Hope this helps!

Thanks, thumbnailers looks to be installed already:

% pikaur -Qs kdegraphics-thumbnailers
local/kdegraphics-thumbnailers 21.08.2-1 (kde-applications kde-graphics)
    Thumbnailers for various graphics file formats

Unfortunately then I have no idea for you.

As odd as it may sound, try to force reinstall the package.

EDIT: Do you also have ffmpegthumbs installed?

Might as well force the reinstallation of both:

pamac reinstall ffmpegthumbs kdegraphics-thumbnailers
1 Like

Thanks again for your suggestions. Had already tried to reinstall kdegraphics-thumbnailers, now also tried to reinstall both of those packages. Still no luck.

Could there be some other package that is somehow “taking over” and failing to produce these previews?

I guess that other some thumbnails generators broke the PDF thumbnail generator.

Can you try to disable other some thumnails generators, if it works?

You can compare my previews (default):

Good idea actually, didn’t think of that. I turned off all except the PS/PDF/DVI, but it still didn’t show preview. Tried to restart Dolphin after this change, though that shouldn’t have an effect I think (the other previews show/hide as soon as I click apply).

I thought of another obvious thing to try. I created a new user and checked if it worked there, with a “fresh kde config”. For this user preview worked just as expected, so there is something wrong in my configuration and not in terms of missing packages at least.

Searching for “how to reset all kde settings” (or more specific, dolphin), it looks like the only real way to do it is by creating a new user and copying over the files from home directory I want to keep? Is there really no “wipe my kde config” out there?

  • Try to remove the directory ~/.cache/dolphin or move it to backup.
  • The config file ~/.config/dolphinrc too.
  • ~/.local/share/dolphin too

Did you install any dolphin plugins that broke the PDF preview?
Dolphin → Preferences → Context Menu → Download New Services

1 Like

Yay, finally found it. I finally just started to move each . folder in my home away and see if I could make preview come back (e.g. mv .cache .cache.bak), restart dolphin and see. This brought me to ~/.local, then to ~/.local/share, finally to ~/.local/share/mime

Here I found some entries from back when I had installed this stupid WPS office package, which puts crap all over the system I feel. I had uninstalled it long ago but the configs were kept I suppose. I removed most of these without checking one-by-one, finally finding the line application/wps-office.pdf in ~/.local/share/mime/types to be the one to disable (but it could be others as well).

So in sum, if someone else encounters a similar issue, have a look at (re)moving ~/.local/share/mime/ or at least look for potential source of your problem there.

Edit: Thanks Zesko, this wasn’t the source of my problem in the end but you put me on the right track :partying_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.