No mouse cursor, everything else working

A booted into Gnome today, but have no mouse cursor. I have tried updating the system, even with Syyu and switched to a slightly newer kernel, but that didn’t help. The keyboard works normally, but the laptop pad does nothing and no cursor is visible. It isn’t invisible, as I’ve checked to see if it does anything when moved to the extremities of the screen. So the mouse pad does nothing. I’m not sure what would be causing this. Anyone encountered this or have an idea what could be the cause?

Probably a hardware problem. But you won’t know that for certain until you’ve tried booting up from the live USB, or if you have a multi-boot system, with another operating system installed on the same machine.

I did think of that, but I’m currently away and don’t have a spare USB drive, or way to get the ISO. Any other ideas or alternative ways to check the hardware?

An alternative would be to try and use a USB mouse.

It could also be the mouse pointer theme…


Thanks, but I’m away from home, I don’t have a USB mouse. I will try and buy one tomorrow if there are no other ideas.

Well, you could try creating a second user account and log in with it. If it doesn’t exhibit the problem, then it’s something in your original home directory. If on the other hand it does exhibit the problem, then it is at the least system-wide, although there is then as yet no evidence that it would be hardware.

See if you can buy a USB stick somewhere, and putting an ISO on it is easy if you use ventoy — it’s in the repository if you don’t have it installed already. With ventoy you format the stick, and then you simply copy the ISO onto the folder on the stick. If you then boot up from it, it’ll give you a menu with every ISO on the stick — you can use it with all kinds of ISOs.

Also, as @Mirdarthos said, see if it works with an external mouse. That could be a clue that it would indeed be the touchpad, or the cable between the touchpad and the motherboard.

1 Like

Thanks for all the suggestions, I have used Ventoy and have it installed, so I will try that tomorrow. I will also try creating a new user.