No more summer time in Night Color?

I don’t know if this has been since the recent update (Sep 18 2023) or been there earlier, but I would have noticed so I’m pretty sure this is very recent.
When I set the switching time to: Sunset and sunrise at current location
the 45 min changing filter begins dimming one hour late (and accordingly finishes one hour late too of course).
I can set it Sunset and sunrise at manual location (pretty accurately by mouse) and it sets it fine on time.
I get this both on laptop and desktop (Stable) so my conclusion is, it must be a bug that daylight saving time i. e. summer time <> winter time is not taken into account anymore with the at current location setting.
I remember it was fine until recently seeing the sun set and the displays dim simultaneously.
Oh and I use a blue dim for day and night (around 5000K/around 2200K).

Do the times shown on the bottom of the night color settings page look plausible?
Do you see the same behaviour for a fresh user?
Did you look if there is an open bug matching your description/symptoms upstream or possibly opened one yourself?

Yes, the times show correct, but it’s nevertheless 1 hour late.
No, I don’t want to try too much for lack of time during sunset/sunrise resp. the principle “Never change a running system” or I’m just scared of it but I will test from a live system soonish. Plus I can work around it fine too.
No, but I will look right now, thank you. No there’s no such active thread with “Night Color” for August or September 2023.

How does it “automatically” know where you are (as opposed to the manual setting?)

Yes, the latitude and longitude show up correctly too.
This way I can get the info to set my location manually in Night Color.
It says my device’s location would be “periodically updated using GPS […] or by sending network information to Mozilla Location Service.”
Guess the location is calculated from my IP address.

Night color switching just workd as expected during sunrise on my manually set location.
Try cleaning KDE cache: KDE - ArchWiki

This may or may not be related. I noticed the same happening here. At first, I thought the router time was set incorrectly (still set to ISP/supplier defaults) as it had been once before (one hour difference), but no, it was in sync. The annoyance remained.

Then I tried setting system locale to en_AU, in its entirety – I had previously been using a separate time locale to allow 24/hr YYYY-MM-DD formatting. The annoyance persisted. Eventually I learned to ignore it.

Maybe these points will help while searching for a solution. Cheers.

Update:- Oops. Apologies, all of the above was true in macOS which I happen to be writing from currently, not in Manjaro; though some of the points may still be worth investigating. Cheers.

the kde background service is running? (in the kde settings)

I think you mean: Automatic Location for Night Color?
If so, yes.